summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/pisg/ChangeLog7
-rw-r--r--net-irc/pisg/Manifest12
-rw-r--r--net-irc/pisg/files/digest-pisg-0.581
-rw-r--r--net-irc/pisg/pisg-0.58.ebuild54
4 files changed, 63 insertions, 11 deletions
diff --git a/net-irc/pisg/ChangeLog b/net-irc/pisg/ChangeLog
index 1785c05f9398..139c3c1947fe 100644
--- a/net-irc/pisg/ChangeLog
+++ b/net-irc/pisg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/pisg
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/ChangeLog,v 1.13 2004/08/28 02:16:23 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/ChangeLog,v 1.14 2004/09/09 14:16:52 swegener Exp $
+
+*pisg-0.58 (09 Sep 2004)
+
+ 09 Sep 2004; Sven Wegener <swegener@gentoo.org> +pisg-0.58.ebuild:
+ Version bump.
*pisg-0.57 (28 Aug 2004)
diff --git a/net-irc/pisg/Manifest b/net-irc/pisg/Manifest
index 5fa57b351eea..4a20fe291af9 100644
--- a/net-irc/pisg/Manifest
+++ b/net-irc/pisg/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 e9eefda3d4e189a0db1b235d26eb9762 ChangeLog 2286
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 4f833d84c390674efeba3a06a5151e04 pisg-0.51.ebuild 1031
MD5 ebd96b4259b4aa888cfe5c47ebe66397 pisg-0.56.ebuild 1256
MD5 db0c0dd002a6c9d35cfbcd0b754f616a pisg-0.57.ebuild 1236
+MD5 db0c0dd002a6c9d35cfbcd0b754f616a pisg-0.58.ebuild 1236
MD5 2116a6e5786030640b4a7f25159dbfc6 files/0.56-network-option-fix.patch 1345
MD5 d1bbe01fcf4658d44fe890463108b7be files/digest-pisg-0.51 61
MD5 48cee577d969a5b7d4feba727deff84f files/digest-pisg-0.56 61
MD5 9de11d80cf02a7d17db1351fe63fc0ba files/digest-pisg-0.57 61
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.5 (GNU/Linux)
-
-iD8DBQFBL+r9I1lqEGTUzyQRAi8FAKDeANcK9ojWqP3wuS1+iGI/K0a2mgCfWQs/
-q76718DpuzhXWCKgjmZMkTI=
-=DOyH
------END PGP SIGNATURE-----
+MD5 3c97207f955bb7df8a99958d56db7ce4 files/digest-pisg-0.58 61
diff --git a/net-irc/pisg/files/digest-pisg-0.58 b/net-irc/pisg/files/digest-pisg-0.58
new file mode 100644
index 000000000000..0c39423a95f9
--- /dev/null
+++ b/net-irc/pisg/files/digest-pisg-0.58
@@ -0,0 +1 @@
+MD5 162f9a8ab38f1df0216182a9091dc56a pisg-0.58.tar.gz 202982
diff --git a/net-irc/pisg/pisg-0.58.ebuild b/net-irc/pisg/pisg-0.58.ebuild
new file mode 100644
index 000000000000..67ac65716486
--- /dev/null
+++ b/net-irc/pisg/pisg-0.58.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/pisg-0.58.ebuild,v 1.1 2004/09/09 14:16:52 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="Perl IRC Statistics Generator"
+HOMEPAGE="http://pisg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Text-Iconv"
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.56-network-option-fix.patch
+
+ sed -i 's!lang\.txt!/usr/share/pisg/lang.txt!' modules/Pisg.pm
+ sed -i 's!layout/!/usr/share/pisg/layout/!' modules/Pisg.pm
+}
+
+src_install () {
+ eval `perl -V:installprivlib`
+
+ dobin pisg
+
+ dodir ${installprivlib}
+ cp -r modules/* ${D}/${installprivlib}
+
+ dodir /usr/share/pisg
+ cp -r gfx layout lang.txt ${D}/usr/share/pisg
+
+ dodoc \
+ docs/{CREDITS,Changelog,FORMATS,pisg-doc.txt} \
+ docs/dev/API pisg.cfg README
+ dohtml docs/html/*
+
+ find ${D}/usr/{lib,share} -type d -exec chmod 755 {} \;
+ find ${D}/usr/{lib,share} -type f -exec chmod 644 {} \;
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The pisg images have been installed in /usr/share/pisg/gfx"
+ einfo
+}