summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/ChangeLog8
-rw-r--r--net-im/licq/files/digest-licq-1.3.4-r13
-rw-r--r--net-im/licq/licq-1.3.4-r1.ebuild207
3 files changed, 217 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 05f06354f1eb..66f98eab6314 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/licq
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.85 2006/10/19 09:37:22 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.86 2006/10/22 15:28:39 voxus Exp $
+
+*licq-1.3.4-r1 (22 Oct 2006)
+
+ 22 Oct 2006; Konstantin V. Arkhipov <voxus@gentoo.org> -licq-1.3.4.ebuild,
+ +licq-1.3.4-r1.ebuild:
+ Closing bugs #149464 and #151980.
19 Oct 2006; Konstantin V. Arkhipov <voxus@gentoo.org> licq-1.3.4.ebuild:
Unneeded patch dropped, closing bug #151912.
diff --git a/net-im/licq/files/digest-licq-1.3.4-r1 b/net-im/licq/files/digest-licq-1.3.4-r1
new file mode 100644
index 000000000000..d66883ce487b
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.3.4-r1
@@ -0,0 +1,3 @@
+MD5 3bab0c9d1977f9b14421d36110e17e0c licq-1.3.4.tar.bz2 3088438
+RMD160 2251da50f5a37903b57cf74d331b4ead693f4e23 licq-1.3.4.tar.bz2 3088438
+SHA256 eed39b1fa78d6c03655babc6cb03155ed71391ec1422752d0611bd2583c2f608 licq-1.3.4.tar.bz2 3088438
diff --git a/net-im/licq/licq-1.3.4-r1.ebuild b/net-im/licq/licq-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..cf55e577e73a
--- /dev/null
+++ b/net-im/licq/licq-1.3.4-r1.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.3.4-r1.ebuild,v 1.1 2006/10/22 15:28:39 voxus Exp $
+
+inherit eutils kde-functions multilib
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~ia64 ~amd64"
+IUSE="ssl socks5 qt3 kde ncurses crypt msn"
+
+# we can't have conditional dependencies so "use kde && inherit kde"
+# won't work -- messes up dep caching.
+
+# need-kde and their eclass friends inject things into DEPEND. But we only
+# want them enabled if the kde USE flag is set. We get around this in the
+# following dep lines:
+RDEPEND="kde? ( >=kde-base/kdelibs-3.0 )"
+DEPEND="kde? ( >=kde-base/kdelibs-3.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt3? ( =x11-libs/qt-3* )
+ ncurses? ( sys-libs/ncurses >=dev-libs/cdk-4.9.11.20031210-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ use ncurses && epatch ${FILESDIR}/1.3.0-suse_bool.patch
+
+ if use kde
+ then
+ # fix for #12436
+ ebegin "Setting kde plugin as default"
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = kde-gui:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ else
+ if ! use qt3
+ then
+ ebegin "Setting console plugin as default..."
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = console:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ fi
+ fi
+
+ # Install plugins in the correct libdir
+ sed -i -e "s:lib/licq/:$(get_libdir)/licq/:" \
+ ${S}/include/licq_constants.h || die "sed failed"
+ sed -i -e 's:$(prefix)/lib:@libdir@:' \
+ ${S}/plugins/*/src/Makefile.{in,am} || die "sed failed"
+}
+
+src_compile() {
+
+ use ssl || myconf="${myconf} --disable-openssl"
+ use socks5 && myconf="${myconf} --enable-socks5"
+
+ if use crypt
+ then
+ myconf="${myconf} --enable-gpgme"
+ else
+ myconf="${myconf} --disable-gpgme"
+ fi
+
+ cd ${S}
+
+ # bug #21009
+ find . -name 'configure' -exec sed -e "s:sed 's/-g:sed 's/^-g:" -i {} \;
+
+ econf ${myconf} || die
+
+ use crypt && {
+ # workaround for gpgme's headers inclusion path
+ sed \
+ -e "s:FAULT_INCLUDES =:FAULT_INCLUDES = -I/usr/include/gpgme:" \
+ -i ${S}/src/Makefile
+ }
+
+ emake || die
+
+ # Create the various plug-ins
+
+ # First, the Qt plug-in
+ if use qt3
+ then
+ set-qtdir 3
+ set-kdedir 3
+
+ use kde && myconf="${myconf} --with-kde"
+
+ # Problems finding qt on multilib systems
+ myconf="${myconf} --with-qt-libraries=${QTDIR}/$(get_libdir)"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd ${S}/plugins/qt-gui
+ einfo "Compiling Qt GUI plug-in"
+ econf ${myconf} || die
+ emake || die
+ fi
+
+ # Now the console plug-in
+ if use ncurses
+ then
+ cd ${S}/plugins/console
+ einfo "Compiling the Console plug-in"
+ econf || die
+ emake || die
+ fi
+
+ # The Auto-Responder plug-in
+ cd ${S}/plugins/auto-reply
+ einfo "Compiling the Auto-Reply plug-in"
+ econf || die
+ emake || die
+
+ # The Remote Management Service
+ cd ${S}/plugins/rms
+ einfo "Compiling Remote Management Services plug-in"
+ econf || die
+ emake || die
+
+ # MSN PLugin
+ if use msn
+ then
+ cd ${S}/plugins/msn
+ einfo "Compiling MSN plug-in"
+ econf || die
+ emake || die
+ fi
+
+ # Email PLugin
+ cd ${S}/plugins/email
+ einfo "Compiling Email plug-in"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog INSTALL README* doc/*
+
+ # Install the plug-ins
+ if use qt3
+ then
+ cd ${S}/plugins/qt-gui
+ make DESTDIR=${D} install || die
+ docinto plugins/qt-gui
+ dodoc README*
+
+ fi
+
+ if use ncurses
+ then
+ cd ${S}/plugins/console
+ make DESTDIR=${D} install || die
+ docinto plugins/console
+ dodoc README
+ fi
+
+ if use msn
+ then
+ cd ${S}/plugins/msn
+ make DESTDIR=${D} install || die
+ docinto plugins/msn
+ dodoc README
+ fi
+
+ cd ${S}/plugins/auto-reply
+ make DESTDIR=${D} install || die
+ docinto plugins/auto-reply
+ dodoc README licq_autoreply.conf
+
+ cd ${S}/plugins/rms
+ make DESTDIR=${D} install || die
+ docinto plugins/rms
+ dodoc README licq_rms.conf
+
+ exeinto /usr/share/${PN}/upgrade
+ doexe ${S}/upgrade/*
+
+ # fixes bug #22136 and #149464
+ rm -fR ${D}/var
+}
+
+pkg_postinst() {
+ echo
+ ewarn
+ ewarn "If you're upgrading from <=licq-1.3.0 - you have to manually "
+ ewarn "upgrade your existing licq installation. Please backup your "
+ ewarn "settings and look into: /usr/share/licq/upgrade for scripts."
+ ewarn
+ echo
+}