summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/amsn/ChangeLog9
-rw-r--r--net-im/amsn/amsn-0.97.2-r1.ebuild74
-rw-r--r--net-im/amsn/files/amsn-0.97.2-TkCximage.patch113
-rw-r--r--net-im/amsn/files/amsn-0.97.2-http-fix.patch22
4 files changed, 217 insertions, 1 deletions
diff --git a/net-im/amsn/ChangeLog b/net-im/amsn/ChangeLog
index 0bf9b736a040..5da27b6d0dec 100644
--- a/net-im/amsn/ChangeLog
+++ b/net-im/amsn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/amsn
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/ChangeLog,v 1.83 2009/01/12 05:59:58 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/ChangeLog,v 1.84 2009/02/01 01:22:33 tester Exp $
+
+*amsn-0.97.2-r1 (01 Feb 2009)
+
+ 01 Feb 2009; Olivier Crête <tester@gentoo.org>
+ +files/amsn-0.97.2-TkCximage.patch, +files/amsn-0.97.2-http-fix.patch,
+ +amsn-0.97.2-r1.ebuild:
+ Add fixes for tcltk 8.5.6 compat, bug #255728
12 Jan 2009; Olivier Crête <tester@gentoo.org>
-files/amsn-0.96-dos.patch, -files/amsn-0.97_rc1-autoconf-logic.patch,
diff --git a/net-im/amsn/amsn-0.97.2-r1.ebuild b/net-im/amsn/amsn-0.97.2-r1.ebuild
new file mode 100644
index 000000000000..045da13d283d
--- /dev/null
+++ b/net-im/amsn/amsn-0.97.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/amsn/amsn-0.97.2-r1.ebuild,v 1.1 2009/02/01 01:22:33 tester Exp $
+
+inherit autotools eutils fdo-mime gnome2-utils
+
+MY_P=${P/_rc/RC}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Alvaro's Messenger client for MSN"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.amsn-project.net"
+
+# The tests are interactive
+RESTRICT="test"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc -sparc ~x86"
+IUSE="debug static"
+
+DEPEND=">=dev-lang/tcl-8.4
+ >=dev-lang/tk-8.4
+ >=dev-tcltk/tls-1.4.1
+ media-libs/jpeg
+ media-libs/libpng
+ >=dev-tcltk/snack-2.2.10"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.97_rc1-nostrip.patch"
+ epatch "${FILESDIR}/amsn-0.97.2-http-fix.patch"
+ epatch "${FILESDIR}/amsn-0.97.2-TkCximage.patch"
+ eautoconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure script failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AGREEMENT TODO README FAQ CREDITS
+
+ domenu amsn.desktop
+ sed -i -e s:.png:: "${D}/usr/share/applications/amsn.desktop"
+
+ cd desktop-icons
+ for i in *; do
+ if [ -e ${i}/msn.png ]; then
+ insinto /usr/share/icons/hicolor/${i}/apps
+ doins ${i}/msn.png
+ fi
+ done
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ ewarn "You might have to remove ~/.amsn prior to running as user if amsn hangs on start-up."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/net-im/amsn/files/amsn-0.97.2-TkCximage.patch b/net-im/amsn/files/amsn-0.97.2-TkCximage.patch
new file mode 100644
index 000000000000..33c5edb4ea14
--- /dev/null
+++ b/net-im/amsn/files/amsn-0.97.2-TkCximage.patch
@@ -0,0 +1,113 @@
+--- trunk/amsn/utils/TkCximage/src/TkCximage.cpp 2008/10/03 21:20:28 10549
++++ trunk/amsn/utils/TkCximage/src/TkCximage.cpp 2008/12/28 21:50:08 10818
+@@ -26,6 +26,65 @@
+ char currenttime[30];
+ FILE * logfile;
+
++#define AVAILABLE_FORMATS 6
++Tk_PhotoImageFormat cximageFormats[] = {
++ {
++ "cximage",
++ (Tk_ImageFileMatchProc *) ChanMatch,
++ (Tk_ImageStringMatchProc *) ObjMatch,
++ (Tk_ImageFileReadProc *) ChanRead,
++ (Tk_ImageStringReadProc *) ObjRead,
++ (Tk_ImageFileWriteProc *) ChanWrite,
++ (Tk_ImageStringWriteProc *) StringWrite
++ },
++ {
++ "cxgif",
++ (Tk_ImageFileMatchProc *) ChanMatch,
++ (Tk_ImageStringMatchProc *) ObjMatch,
++ (Tk_ImageFileReadProc *) ChanRead,
++ (Tk_ImageStringReadProc *) ObjRead,
++ (Tk_ImageFileWriteProc *) ChanWrite,
++ (Tk_ImageStringWriteProc *) StringWrite
++ },
++ {
++ "cxpng",
++ (Tk_ImageFileMatchProc *) ChanMatch,
++ (Tk_ImageStringMatchProc *) ObjMatch,
++ (Tk_ImageFileReadProc *) ChanRead,
++ (Tk_ImageStringReadProc *) ObjRead,
++ (Tk_ImageFileWriteProc *) ChanWrite,
++ (Tk_ImageStringWriteProc *) StringWrite
++ },
++ {
++ "cxjpg",
++ (Tk_ImageFileMatchProc *) ChanMatch,
++ (Tk_ImageStringMatchProc *) ObjMatch,
++ (Tk_ImageFileReadProc *) ChanRead,
++ (Tk_ImageStringReadProc *) ObjRead,
++ (Tk_ImageFileWriteProc *) ChanWrite,
++ (Tk_ImageStringWriteProc *) StringWrite
++ },
++ {
++ "cxtga",
++ (Tk_ImageFileMatchProc *) ChanMatch,
++ (Tk_ImageStringMatchProc *) ObjMatch,
++ (Tk_ImageFileReadProc *) ChanRead,
++ (Tk_ImageStringReadProc *) ObjRead,
++ (Tk_ImageFileWriteProc *) ChanWrite,
++ (Tk_ImageStringWriteProc *) StringWrite
++ },
++ {
++ "cxbmp",
++ (Tk_ImageFileMatchProc *) ChanMatch,
++ (Tk_ImageStringMatchProc *) ObjMatch,
++ (Tk_ImageFileReadProc *) ChanRead,
++ (Tk_ImageStringReadProc *) ObjRead,
++ (Tk_ImageFileWriteProc *) ChanWrite,
++ (Tk_ImageStringWriteProc *) StringWrite
++ }
++};
++
++
+ int RGB2BGR(Tk_PhotoImageBlock *data, BYTE * pixelPtr) {
+ int i;
+ int size = data->height * data->width * data->pixelSize;
+@@ -267,10 +326,6 @@
+ INITLOGS(); //
+ LOG("---------------------------------"); //
+
+-
+- int AvailableFromats = 6;
+- const char *KnownFormats[] = {"cximage", "cxgif", "cxpng", "cxjpg", "cxtga", "cxbmp"};
+-
+ //Check Tcl version is 8.3 or higher
+ if (Tcl_InitStubs(interp, TCL_VERSION, 1) == NULL) {
+ return TCL_ERROR;
+@@ -285,15 +340,6 @@
+
+ LOG("Tk stub initialized"); //
+
+- Tk_PhotoImageFormat cximageFormats = {
+- NULL,
+- (Tk_ImageFileMatchProc *) ChanMatch,
+- (Tk_ImageStringMatchProc *) ObjMatch,
+- (Tk_ImageFileReadProc *) ChanRead,
+- (Tk_ImageStringReadProc *) ObjRead,
+- (Tk_ImageFileWriteProc *) ChanWrite,
+- (Tk_ImageStringWriteProc *) StringWrite
+- };
+
+ LOG("Creating commands"); //
+
+@@ -323,14 +369,9 @@
+ #endif
+
+ LOG("Adding format : "); //
+- for (i = 0; i < AvailableFromats; i++) {
+- delete cximageFormats.name;
+- cximageFormats.name = new char[strlen(KnownFormats[i]) + 1];
+- strcpy(cximageFormats.name, KnownFormats[i]);
+- Tk_CreatePhotoImageFormat(&cximageFormats);
+- APPENDLOG(cximageFormats.name); //
+- delete cximageFormats.name;
+- cximageFormats.name = NULL;
++ for (i = 0; i < AVAILABLE_FORMATS; i++) {
++ Tk_CreatePhotoImageFormat(&cximageFormats[i]);
++ APPENDLOG(cximageFormats[i].name); //
+ }
+
+ // end of Initialisation
diff --git a/net-im/amsn/files/amsn-0.97.2-http-fix.patch b/net-im/amsn/files/amsn-0.97.2-http-fix.patch
new file mode 100644
index 000000000000..d5b2d093db29
--- /dev/null
+++ b/net-im/amsn/files/amsn-0.97.2-http-fix.patch
@@ -0,0 +1,22 @@
+--- trunk/amsn/autoupdate.tcl 2008/03/11 20:50:28 9648
++++ trunk/amsn/autoupdate.tcl 2008/11/14 16:47:29 10726
+@@ -540,7 +540,7 @@
+ }
+
+ #///////////////////////////////////////////////////////////////////////
+- package require http
++ package require -exact http 2.4.4
+
+ proc check_web_version { token } {
+ global version rcversion weburl
+--- trunk/amsn/proxy.tcl 2008/10/27 18:05:35 10649
++++ trunk/amsn/proxy.tcl 2008/11/14 16:47:29 10726
+@@ -9,7 +9,7 @@
+ ::Version::setSubversionId {$Id: amsn-0.97.2-http-fix.patch,v 1.1 2009/02/01 01:22:32 tester Exp $}
+
+ package provide Proxy 0.1
+-package require http
++package require -exact http 2.4.4
+
+ # This should be converted to a proper package, to use with package require
+ source socks.tcl ;# SOCKS5 proxy support