summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/vacuum')
-rw-r--r--net-im/vacuum/ChangeLog9
-rw-r--r--net-im/vacuum/metadata.xml5
-rw-r--r--net-im/vacuum/vacuum-1.2.0.ebuild79
-rw-r--r--net-im/vacuum/vacuum-9999.ebuild7
4 files changed, 96 insertions, 4 deletions
diff --git a/net-im/vacuum/ChangeLog b/net-im/vacuum/ChangeLog
index 1170f181f318..31e48473a081 100644
--- a/net-im/vacuum/ChangeLog
+++ b/net-im/vacuum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/vacuum
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.6 2012/03/10 20:20:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.7 2012/08/01 07:49:23 maksbotan Exp $
+
+*vacuum-1.2.0 (01 Aug 2012)
+
+ 01 Aug 2012; Maxim Koltsov <maksbotan@gentoo.org> +vacuum-1.2.0.ebuild,
+ metadata.xml, vacuum-9999.ebuild:
+ Bump to 1.2.0, bug #429084. Thanks to Nikoli
10 Mar 2012; Mike Frysinger <vapier@gentoo.org> vacuum-1.1.2.ebuild,
vacuum-9999.ebuild:
@@ -34,4 +40,3 @@
Add net-im/vacuum-1.1.0 and 9999, thanks to Nikoli(nikoli@lavabit.com),
fixes
bug #296004
-
diff --git a/net-im/vacuum/metadata.xml b/net-im/vacuum/metadata.xml
index 733cb18e0237..a274b6cd2b50 100644
--- a/net-im/vacuum/metadata.xml
+++ b/net-im/vacuum/metadata.xml
@@ -27,6 +27,7 @@
<flag name="dataforms">Allow other modules to process and display data forms intended for the user</flag>
<flag name="datastreamsmanager">Enable initiating a custom data stream between two XMPP entities</flag>
<flag name="emoticons">Enable using smiley images in messages</flag>
+ <flag name="filemessagearchive">Allows to save the history of conversations to local files</flag>
<flag name="filestreamsmanager">Enable transferring files between two XMPP entities</flag>
<flag name="filetransfer">Enable sending files to peers</flag>
<flag name="gateways">Simplify the interaction with gateways to other IM systems</flag>
@@ -40,10 +41,14 @@
<flag name="privatestorage">Allow other modules to store arbitrary data on the server</flag>
<flag name="registration">Enable creating accounts in Jabber services</flag>
<flag name="remotecontrol">Allows to remotely control the client</flag>
+ <flag name="rosteritemexchange">Allows to exchange contact list items</flag>
<flag name="rostersearch">Allows to search for contacts in the roster</flag>
+ <flag name="servermessagearchive">Allows to save the history of communications on the server</flag>
<flag name="servicediscovery">Enable receiving information about Jabber entities</flag>
<flag name="sessionnegotiation">Enable initiating the session between two entities with setting the rules for XMPP stanzas exchange</flag>
+ <flag name="shortcutmanager">Allows to setup user defined shortcuts</flag>
<flag name="socksstreams">Enable initiating SOCKS5 data streams between two XMPP entities</flag>
+ <flag name="urlprocessor">Allows other plugins to load data from custom types of URLs</flag>
<flag name="vcard">Enable obtaining peer's personal contact information</flag>
<flag name="xmppuriqueries">Allow other plugins to handle XMPP URI queries</flag>
<flag name="vcs-revision">Add VCS revision to version number, INSECURE.</flag>
diff --git a/net-im/vacuum/vacuum-1.2.0.ebuild b/net-im/vacuum/vacuum-1.2.0.ebuild
new file mode 100644
index 000000000000..be07cd28aac6
--- /dev/null
+++ b/net-im/vacuum/vacuum-1.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.2.0.ebuild,v 1.1 2012/08/01 07:49:23 maksbotan Exp $
+
+EAPI="4"
+LANGS="de pl ru uk"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Crossplatform Jabber client."
+HOMEPAGE="http://code.google.com/p/vacuum-im"
+SRC_URI="http://vacuum-im.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries"
+IUSE="${PLUGINS// / +}"
+for x in ${LANGS}; do
+ IUSE+=" linguas_${x}"
+done
+
+REQUIRED_USE="
+ annotations? ( privatestorage )
+ avatars? ( vcard )
+ birthdayreminder? ( vcard )
+ bookmarks? ( privatestorage )
+ captchaforms? ( dataforms )
+ commands? ( dataforms )
+ datastreamsmanager? ( dataforms )
+ filemessagearchive? ( messagearchiver )
+ filestreamsmanager? ( datastreamsmanager )
+ filetransfer? ( filestreamsmanager datastreamsmanager )
+ pepmanager? ( servicediscovery )
+ registration? ( dataforms )
+ remotecontrol? ( commands dataforms )
+ servermessagearchive? ( messagearchiver )
+ sessionnegotiation? ( dataforms )
+"
+
+RDEPEND="
+ >=x11-libs/qt-core-4.5:4[ssl]
+ >=x11-libs/qt-gui-4.5:4
+ >=dev-libs/openssl-0.9.8k
+ adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
+ net-dns/libidn
+ x11-libs/libXScrnSaver
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS CHANGELOG README TRANSLATORS"
+
+src_prepare() {
+ # Force usage of system libraries
+ rm -rf src/thirdparty/{idn,minizip,zlib}
+}
+
+src_configure() {
+ # linguas
+ local langs="none;" x
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+="${x};"
+ done
+
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="$(get_libdir)"
+ -DINSTALL_SDK=ON
+ -DLANGS="${langs}"
+ -DINSTALL_DOCS=OFF
+ -DFORCE_BUNDLED_MINIZIP=OFF
+ )
+
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( "$(cmake-utils_use ${x} PLUGIN_${x})" )
+ done
+
+ cmake-utils_src_configure
+}
diff --git a/net-im/vacuum/vacuum-9999.ebuild b/net-im/vacuum/vacuum-9999.ebuild
index c84f4a79f71b..3720f06f411f 100644
--- a/net-im/vacuum/vacuum-9999.ebuild
+++ b/net-im/vacuum/vacuum-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.4 2012/03/10 20:20:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.5 2012/08/01 07:49:23 maksbotan Exp $
EAPI="4"
LANGS="de pl ru uk"
@@ -14,7 +14,7 @@ ESVN_REPO_URI="http://vacuum-im.googlecode.com/svn/trunk"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rostersearch servicediscovery sessionnegotiation socksstreams vcard xmppuriqueries"
+PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries"
IUSE="${PLUGINS// / +} vcs-revision"
for x in ${LANGS}; do
IUSE+=" linguas_${x}"
@@ -23,15 +23,18 @@ done
REQUIRED_USE="
annotations? ( privatestorage )
avatars? ( vcard )
+ birthdayreminder? ( vcard )
bookmarks? ( privatestorage )
captchaforms? ( dataforms )
commands? ( dataforms )
datastreamsmanager? ( dataforms )
+ filemessagearchive? ( messagearchiver )
filestreamsmanager? ( datastreamsmanager )
filetransfer? ( filestreamsmanager datastreamsmanager )
pepmanager? ( servicediscovery )
registration? ( dataforms )
remotecontrol? ( commands dataforms )
+ servermessagearchive? ( messagearchiver )
sessionnegotiation? ( dataforms )
"