summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/ekg/ekg-1.6_rc1.ebuild')
-rw-r--r--net-im/ekg/ekg-1.6_rc1.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/net-im/ekg/ekg-1.6_rc1.ebuild b/net-im/ekg/ekg-1.6_rc1.ebuild
index 460dd1721990..914a5cf391bc 100644
--- a/net-im/ekg/ekg-1.6_rc1.ebuild
+++ b/net-im/ekg/ekg-1.6_rc1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.6_rc1.ebuild,v 1.1 2005/03/20 17:45:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.6_rc1.ebuild,v 1.1.1.1 2005/11/30 10:09:49 chriswhite Exp $
-IUSE="ssl ncurses zlib python spell"
+inherit eutils
+
+IUSE="ssl ncurses zlib python spell threads"
DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
HOMEPAGE="http://dev.null.pl/ekg/"
@@ -10,7 +12,7 @@ SRC_URI="http://dev.null.pl/ekg/${P/_/}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa ~mips ~ia64 ~amd64"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa ~mips ia64 ~amd64"
S="${WORKDIR}/${P/_/}"
@@ -21,13 +23,20 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
python? ( dev-lang/python )
spell? ( >=app-text/aspell-0.50.3 )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ekg-1.6_rc1-fpic.patch
+}
+
src_compile() {
- local myconf="--enable-ioctld --enable-shared --with-pthread --enable-dynamic"
+ local myconf="--enable-ioctld --enable-shared --enable-dynamic"
use ssl || myconf="$myconf --disable-openssl"
use ncurses || myconf="$myconf --disable-ui-ncurses --enable-ui-readline"
use zlib || myconf="$myconf --disable-zlib"
use python && myconf="$myconf --with-python"
use spell && myconf="$myconf --enable-aspell"
+ use threads && myconf="$myconf --with-pthread"
econf ${myconf} || die
emake || die