summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/libnfs/libnfs-9999.ebuild')
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 424df33f9e9b..008aa78d1943 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-9999.ebuild,v 1.2 2012/05/03 04:06:32 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-9999.ebuild,v 1.3 2012/12/04 03:54:39 vapier Exp $
EAPI="4"
-inherit autotools
+inherit eutils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
- inherit git-2
+ inherit git-2 autotools
else
- SRC_URI="https://github.com/sahlberg/${PN}/tarball/${P} -> ${P}.tgz"
+ SRC_URI="https://github.com/downloads/sahlberg/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -20,26 +20,22 @@ LICENSE="LGPL-2.1 GPL-3"
SLOT="0"
IUSE="static-libs"
-RDEPEND="net-libs/libtirpc"
+RDEPEND=""
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_unpack() {
default
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- else
- mv sahlberg-libnfs-* "${S}" || die
- fi
+ [[ ${PV} == "9999" ]] && git-2_src_unpack
}
src_prepare() {
- eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
+ epatch "${FILESDIR}"/${PN}-1.5.0-headers.patch
}
src_configure() {
econf \
- --enable-tirpc \
$(use_enable static-libs static)
}