summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild')
-rw-r--r--net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild b/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild
index 84740dbfbada..e59464393bda 100644
--- a/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild
+++ b/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild,v 1.1 2005/08/06 03:17:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild,v 1.1.1.1 2005/11/30 10:11:17 chriswhite Exp $
IUSE=""
@@ -12,7 +12,7 @@ SRC_URI="http://www.ipp2p.org/downloads/${P}.tar.gz"
SLOT="${KV}"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="amd64 ~ppc sparc x86"
RDEPEND="virtual/modutils
>=net-firewall/iptables-1.2.11"
@@ -33,14 +33,17 @@ src_unpack() {
cd ${S}
convert_to_m ${S}/Makefile
+
+ sed -i -e 's/^IPTABLES_VERSION/#IPTABLES_VERSION/' ${S}/Makefile
}
src_compile() {
- emake CFLAGS="${CFLAGS}" libipt_ipp2p.so || die "Failed to build iptables module"
+ local IPTABLES_VERSION="$(${ROOT}/sbin/iptables --version | cut -f2 -dv)"
+ emake CFLAGS="${CFLAGS}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" libipt_ipp2p.so || die "Failed to build iptables module"
- xarch="${ARCH}"
+ local xarch="${ARCH}"
unset ARCH
- emake KERNEL_SRC="${KV_DIR}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="$(${ROOT}/sbin/iptables --version | cut -f2 -dv)" IPTABLES_BIN="${ROOT}/sbin/iptables" || die "Failed to build kernel modle."
+ emake KERNEL_SRC="${KV_DIR}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" || die "Failed to build kernel modle."
ARCH="${xarch}"
}