summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/fwbuilder/fwbuilder-5.1.0.3599.ebuild')
-rw-r--r--net-firewall/fwbuilder/fwbuilder-5.1.0.3599.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-firewall/fwbuilder/fwbuilder-5.1.0.3599.ebuild b/net-firewall/fwbuilder/fwbuilder-5.1.0.3599.ebuild
new file mode 100644
index 000000000000..2189b3a30450
--- /dev/null
+++ b/net-firewall/fwbuilder/fwbuilder-5.1.0.3599.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-5.1.0.3599.ebuild,v 1.1 2012/06/01 21:30:33 dilfridge Exp $
+
+EAPI="4"
+
+inherit eutils base qt4-r2 multilib autotools
+
+DESCRIPTION="A firewall GUI"
+HOMEPAGE="http://www.fwbuilder.org/"
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-gui-4.3
+ dev-libs/openssl
+ dev-libs/elfutils"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.0.0.3568-ldflags.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+ sed -i -e '/dnl.*AM_INIT_AUTOMAKE/d' configure.in || die #398743
+ eautoreconf
+}
+
+src_configure() {
+ eqmake4
+ # portage handles ccache/distcc itself
+ econf --without-{ccache,distcc}
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ validate_desktop_entries
+
+ elog "You need to emerge sys-apps/iproute2 on the machine"
+ elog "that will run the firewall script."
+}