summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/xc/xc-4.3.2-r1.ebuild')
-rw-r--r--net-dialup/xc/xc-4.3.2-r1.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/net-dialup/xc/xc-4.3.2-r1.ebuild b/net-dialup/xc/xc-4.3.2-r1.ebuild
index 78cc33dda000..a277da1a1d40 100644
--- a/net-dialup/xc/xc-4.3.2-r1.ebuild
+++ b/net-dialup/xc/xc-4.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.17 2008/04/24 16:21:38 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.18 2008/10/18 09:15:32 mrness Exp $
inherit eutils toolchain-funcs
@@ -17,24 +17,18 @@ DEPEND="sys-libs/ncurses"
src_unpack() {
unpack ${A}
- tc-export CC
+
cd "${S}"
- epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
epatch "${FILESDIR}/${P}-implicit-decl.patch"
# Adds 115200 bps support
epatch "${FILESDIR}/${P}-add-115200.patch"
-
- # Fixes the Makefile to use gentoo CFLAGS
- sed -i \
- -e "s:GCCOPT\t= -pipe -O2 -fno-strength-reduce -fomit-frame-pointer:GCCOPT\t= ${CFLAGS} -fno-strength-reduce:g" \
- -e "s:-ltermcap:-lncurses ${LDFLAGS}:" \
- -e 's:CC\t= gcc:CC='${CC}':' \
- Makefile || die
}
src_compile() {
- make WARN="" all prefix=/usr mandir=/usr/share/man || die "make failed"
+ tc-export CC
+ emake WARN="" all prefix=/usr mandir=/usr/share/man || die "make failed"
}
src_install () {