summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/pptpclient/pptpclient-1.1.0-r1.ebuild')
-rw-r--r--net-dialup/pptpclient/pptpclient-1.1.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-dialup/pptpclient/pptpclient-1.1.0-r1.ebuild b/net-dialup/pptpclient/pptpclient-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..84258b8d46e5
--- /dev/null
+++ b/net-dialup/pptpclient/pptpclient-1.1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.1.0-r1.ebuild,v 1.1 2002/11/14 10:51:51 jhhudso Exp $
+
+
+S=${WORKDIR}/pptp-linux-${PV}-1
+DESCRIPTION="Linux client for PPTP"
+HOMEPAGE="http://pptpclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pptpclient/pptp-linux-${PV}-1.tar.gz"
+
+DEPEND="net-dialup/ppp
+ sys-devel/perl
+ tcltk? ( dev-perl/perl-tk )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="tcltk"
+
+src_compile() {
+ cd ${S}
+ tar zxf pptp-linux-${PV}.tar.gz
+ cd ${S}/pptp-linux-${PV}
+
+ make || die "make failed"
+}
+
+src_install() {
+ cd ${S}
+ insinto /etc/ppp
+ doins options.pptp
+ dosbin pptp-command pptp_fe.pl
+
+ if [ -n "`use tcltk`" ] ; then
+ sed s/pptp_fe/pptp_fe.pl/g < xpptp_fe.pl > xpptp_fe.pl.new
+ mv xpptp_fe.pl.new xpptp_fe.pl
+ dosbin xpptp_fe.pl
+ fi
+
+ cd pptp-linux-${PV}
+ dosbin pptp
+
+ dodoc AUTHORS COPYING ChangeLog DEVELOPERS NEWS README TODO USING
+ dodoc Documentation/*
+ dodoc Reference/*
+}
+