summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netcat6/ChangeLog9
-rw-r--r--net-analyzer/netcat6/files/digest-netcat6-1.03
-rw-r--r--net-analyzer/netcat6/netcat6-1.0.ebuild29
3 files changed, 39 insertions, 2 deletions
diff --git a/net-analyzer/netcat6/ChangeLog b/net-analyzer/netcat6/ChangeLog
index 01c68253bfd9..d816abec0b2d 100644
--- a/net-analyzer/netcat6/ChangeLog
+++ b/net-analyzer/netcat6/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/netcat6
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/ChangeLog,v 1.4 2005/10/18 02:02:41 agriffis Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/ChangeLog,v 1.5 2006/02/19 10:15:25 vapier Exp $
+
+*netcat6-1.0 (19 Feb 2006)
+
+ 19 Feb 2006; Mike Frysinger <vapier@gentoo.org> +netcat6-1.0.ebuild:
+ Version bump #123112 by Sascha Geschwandtner.
18 Oct 2005; Aron Griffis <agriffis@gentoo.org> netcat6-0.5.ebuild:
Mark 0.5 stable on alpha
diff --git a/net-analyzer/netcat6/files/digest-netcat6-1.0 b/net-analyzer/netcat6/files/digest-netcat6-1.0
new file mode 100644
index 000000000000..591ff88c3276
--- /dev/null
+++ b/net-analyzer/netcat6/files/digest-netcat6-1.0
@@ -0,0 +1,3 @@
+MD5 5074bc51989420a1f68716f93322030f nc6-1.0.tar.bz2 264257
+RMD160 c5444976925ffece7f27fc1ff3c16ebe19998b78 nc6-1.0.tar.bz2 264257
+SHA256 eb35e7a05a60bf94496075a3a246d7bf63fcdba2ca7ceb6844852a1ff6478206 nc6-1.0.tar.bz2 264257
diff --git a/net-analyzer/netcat6/netcat6-1.0.ebuild b/net-analyzer/netcat6/netcat6-1.0.ebuild
new file mode 100644
index 000000000000..26e668a0220d
--- /dev/null
+++ b/net-analyzer/netcat6/netcat6-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat6/netcat6-1.0.ebuild,v 1.1 2006/02/19 10:15:25 vapier Exp $
+
+DESCRIPTION="netcat clone with better IPv6 support, improved code, etc..."
+HOMEPAGE="http://netcat6.sourceforge.net/"
+SRC_URI="ftp://ftp.deepspace6.net/pub/ds6/sources/nc6/nc6-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 nls"
+
+DEPEND=""
+
+S=${WORKDIR}/nc6-${PV}
+
+src_compile() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS BUGS README NEWS TODO CREDITS ChangeLog
+}