summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog6
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 9e7db26d593c..85720acc1b7a 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.44 2006/01/10 19:50:24 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.45 2006/01/29 00:32:52 eldad Exp $
+
+ 29 Jan 2006; Eldad Zack <eldad@gentoo.org> nagios-plugins-1.3.1-r1.ebuild:
+ Bug 97652: added check for /etc/mtab, as it may be missing in chroot'ed
+ enviornments. The check is only needed for 1.3.1
10 Jan 2006; Gustavo Zacarias <gustavoz@gentoo.org>
nagios-plugins-1.4.2.ebuild:
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
index 9d88e629f003..97fed9231552 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild,v 1.19 2005/07/09 18:26:27 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild,v 1.20 2006/01/29 00:32:52 eldad Exp $
inherit eutils
@@ -34,6 +34,14 @@ pkg_setup() {
}
src_compile() {
+ # check for mtab, as this will otherwise let configure not detect a usable "df" command.
+ if [[ ! -r /etc/mtab ]];
+ then
+ eerror "Can't find /etc/mtab. Are you running under chroot?"
+ eerror "If so copy the /etc/mtab to the chroot'ed enviornment and try again."
+ die "can't find /etc/mtab."
+ fi
+
local myconf
use mysql && myconf="${myconf} --with-mysql" || myconf="${myconf} --without-mysql"
use postgres && myconf="${myconf} --with-pgsql" || myconf="${myconf} --without-pgsql"