summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild')
-rw-r--r--net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild b/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild
index c4267371b0df..3a26298c429a 100644
--- a/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild
+++ b/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild
@@ -1,50 +1,48 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild,v 1.11 2003/09/05 23:40:10 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild,v 1.12 2003/10/10 09:20:58 mr_bones_ Exp $
-S="${WORKDIR}/${P}"
DESCRIPTION="neat graphical traceroute displaying route on the globe"
SRC_URI="http://www.dtek.chalmers.se/~d3august/xt/dl/${P}.tar.gz
http://www.dtek.chalmers.se/~d3august/xt/dl/ndg_files.tar.gz"
HOMEPAGE="http://www.dtek.chalmers.se/~d3august/xt/"
-SLOT="0"
+KEYWORDS="x86 sparc"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
+SLOT="0"
+
+IUSE="nls"
-DEPEND="x11-base/xfree
+DEPEND="virtual/x11
=x11-libs/gtk+-1.2*
net-analyzer/traceroute
<x11-libs/gtkglarea-1.99.0
media-libs/gdk-pixbuf
net-misc/host"
-
-
src_compile() {
# specify --from-code to fix bug 25395 (01 Aug 2003 agriffis)
XGETTEXT='/usr/bin/xgettext --from-code=ISO-8859-1' \
./configure \
+ `use_enable nls` \
--host=${CHOST} \
--prefix=/usr \
--with-host=/usr/bin/hostx \
--infodir=/usr/share/info \
--mandir=/usr/share/man || die "./configure failed"
- emake || die
- #make || die
+ emake || die "emake failed"
}
src_install () {
- #make DESTDIR=${D} install || die
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
- install || die
+ install || die "make install failed"
# Install documentation.
- dodoc AUTHORS COPYING INSTALL NEWS README TODO
+ dodoc AUTHORS NEWS README TODO || die "dodoc failed"
#Install NDG loc database
cd ${D}/usr/share/xtraceroute/