summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nfdump')
-rw-r--r--net-analyzer/nfdump/ChangeLog7
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.6.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/net-analyzer/nfdump/ChangeLog b/net-analyzer/nfdump/ChangeLog
index 558fd432124a..d51f4d04257d 100644
--- a/net-analyzer/nfdump/ChangeLog
+++ b/net-analyzer/nfdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nfdump
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.22 2012/02/21 17:20:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.23 2012/03/28 15:21:56 jer Exp $
+
+*nfdump-1.6.6 (28 Mar 2012)
+
+ 28 Mar 2012; Jeroen Roovers <jer@gentoo.org> +nfdump-1.6.6.ebuild:
+ Version bump.
21 Feb 2012; Jeroen Roovers <jer@gentoo.org> -nfdump-1.6.2.ebuild,
-nfdump-1.6.3_p1.ebuild:
diff --git a/net-analyzer/nfdump/nfdump-1.6.6.ebuild b/net-analyzer/nfdump/nfdump-1.6.6.ebuild
new file mode 100644
index 000000000000..c822cfff2ee6
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.6.ebuild,v 1.1 2012/03/28 15:21:56 jer Exp $
+
+EAPI=4
+inherit autotools eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="http://nfdump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Fails to build readpcap:
+# https://sourceforge.net/tracker/?func=detail&aid=2996582&group_id=119350&atid=683752
+IUSE="compat15 debug ftconv nfprofile sflow"
+
+CDEPEND="
+ ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
+ nfprofile? ( net-analyzer/rrdtool )"
+# readpcap? ( net-libs/libpcap )"
+DEPEND="${CDEPEND}
+ sys-devel/flex"
+RDEPEND=${CDEPEND}"
+ dev-lang/perl"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ if use ftconv; then
+ sed -e '/ftbuild.h/d' -i bin/ft2nfdump.c || die
+ sed \
+ -e 's:lib\(/ftlib.h\):include\1:' \
+ -e 's:libft.a:libft.so:' \
+ \-i configure.in || die
+ fi
+ sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
+ eautoreconf
+}
+
+src_configure() {
+ # --without-ftconf is not handled well #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfprofile && echo "--enable-nfprofile") \
+ $(use_enable sflow) \
+ $(use_enable debug devel) \
+ $(use_enable compat15)
+ # $(use_enable readpcap) \
+}