summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/knocker/knocker-0.7.1.ebuild')
-rw-r--r--net-analyzer/knocker/knocker-0.7.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/knocker/knocker-0.7.1.ebuild b/net-analyzer/knocker/knocker-0.7.1.ebuild
new file mode 100644
index 000000000000..3a4c8192b52d
--- /dev/null
+++ b/net-analyzer/knocker/knocker-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/knocker/knocker-0.7.1.ebuild,v 1.1 2002/07/04 14:38:15 stroke Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Knocker is an easy to use security port scanner written in C"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/knocker/${P}.tar.gz"
+HOMEPAGE="http://knocker.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die "emake died"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog AUTHORS README BUGS TO-DO NEWS
+}