summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/rtmpdump/ChangeLog8
-rw-r--r--media-video/rtmpdump/rtmpdump-2.3.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
index a33212ef4ae1..7af35b063ce5 100644
--- a/media-video/rtmpdump/ChangeLog
+++ b/media-video/rtmpdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/rtmpdump
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.6 2010/06/17 21:56:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.7 2010/07/07 22:25:30 hwoarang Exp $
+
+*rtmpdump-2.3 (07 Jul 2010)
+
+ 07 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +rtmpdump-2.3.ebuild:
+ Version bump. Thanks to Adrian.Bassett@hotmail.co.uk for the ebuild. Fixes
+ bug #326619
*rtmpdump-2.2e-r3 (17 Jun 2010)
diff --git a/media-video/rtmpdump/rtmpdump-2.3.ebuild b/media-video/rtmpdump/rtmpdump-2.3.ebuild
new file mode 100644
index 000000000000..40f6b73b678f
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-2.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.3.ebuild,v 1.1 2010/07/07 22:25:30 hwoarang Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+SRC_URI="http://rtmpdump.mplayerhq.hu/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls polarssl ssl"
+
+DEPEND="ssl? (
+ gnutls? ( net-libs/gnutls )
+ polarssl? ( !gnutls? ( net-libs/polarssl ) )
+ !gnutls? ( !polarssl? ( dev-libs/openssl ) )
+ )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_prepare() {
+ # fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+ sed -i -e 's:OPT=:&-fPIC :' \
+ -e 's:OPT:OPTS:' \
+ -e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
+ || die "failed to fix Makefile"
+}
+
+src_compile() {
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+
+ emake CC=$(tc-getCC) LD=$(tc-getLD) \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix || die "emake failed"
+}
+
+src_install() {
+ mkdir -p "${D}"/${DESTTREE}/lib
+ emake DESTDIR="${D}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
+ CRYPTO="${crypto}" install || die "emake install failed"
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html || die "dodoc failed"
+}