summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/beast')
-rw-r--r--media-sound/beast/ChangeLog5
-rw-r--r--media-sound/beast/beast-0.6.6.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/media-sound/beast/ChangeLog b/media-sound/beast/ChangeLog
index 5d8b786b7fba..b252120387c4 100644
--- a/media-sound/beast/ChangeLog
+++ b/media-sound/beast/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/beast
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.20 2005/10/07 16:42:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.21 2005/12/25 15:01:39 flameeyes Exp $
+
+ 25 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> beast-0.6.6.ebuild:
+ Use bindnow-flags function instead of -Wl,-z,now.
07 Oct 2005; Diego Pettenò <flameeyes@gentoo.org> beast-0.6.4.ebuild,
beast-0.6.5.ebuild, beast-0.6.6.ebuild:
diff --git a/media-sound/beast/beast-0.6.6.ebuild b/media-sound/beast/beast-0.6.6.ebuild
index bf9e6c48d545..9a3ce7c38bba 100644
--- a/media-sound/beast/beast-0.6.6.ebuild
+++ b/media-sound/beast/beast-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.6.6.ebuild,v 1.2 2005/10/07 16:42:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.6.6.ebuild,v 1.3 2005/12/25 15:01:39 flameeyes Exp $
inherit eutils flag-o-matic
@@ -31,7 +31,7 @@ DEPEND="dev-util/pkgconfig
src_compile() {
# avoid suid related security issues.
- append-ldflags -Wl,-z,now
+ append-ldflags $(bindnow-flags)
econf ${myconf} \
$(use_enable debug) \