summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/audacious/audacious-1.2.2.ebuild')
-rw-r--r--media-sound/audacious/audacious-1.2.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/media-sound/audacious/audacious-1.2.2.ebuild b/media-sound/audacious/audacious-1.2.2.ebuild
deleted file mode 100644
index 3866e2641470..000000000000
--- a/media-sound/audacious/audacious-1.2.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.2.ebuild,v 1.7 2007/03/11 01:16:39 kloeri Exp $
-
-inherit flag-o-matic
-
-MY_P=${P/_/-}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
-HOMEPAGE="http://audacious-media-player.org/"
-SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
- mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="chardet nls gnome"
-
-RDEPEND=">=x11-libs/gtk+-2.6
- >=gnome-base/libglade-2.3.1
- dev-libs/libxml2
- gnome? ( >=gnome-base/gconf-2.6.0 )"
-
-DEPEND="${RDEPEND}
- nls? ( dev-util/intltool )
- >=dev-util/pkgconfig-0.9.0"
-
-PDEPEND=">=media-plugins/audacious-plugins-1.2.2"
-
-src_compile() {
- # Bug #42893
- replace-flags "-Os" "-O2"
- # Bug #86689
- is-flag "-O*" || append-flags -O
-
- econf \
- $(use_enable chardet) \
- $(use_enable nls) \
- $(use_enable gnome gconf) \
- || die
-
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS NEWS README
-
- # Gentoo_ice skin installation; bug #109772
- insinto /usr/share/audacious/Skins/gentoo_ice
- doins "${WORKDIR}"/gentoo_ice/*
- docinto gentoo_ice
- dodoc "${WORKDIR}"/README
-}