summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/abcm2ps')
-rw-r--r--media-sound/abcm2ps/ChangeLog7
-rw-r--r--media-sound/abcm2ps/abcm2ps-6.6.15.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/media-sound/abcm2ps/ChangeLog b/media-sound/abcm2ps/ChangeLog
index 4c5a0095de32..b687fb4659e6 100644
--- a/media-sound/abcm2ps/ChangeLog
+++ b/media-sound/abcm2ps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcm2ps
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/ChangeLog,v 1.49 2012/05/05 08:05:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/ChangeLog,v 1.50 2012/05/29 12:29:27 radhermit Exp $
+
+*abcm2ps-6.6.15 (29 May 2012)
+
+ 29 May 2012; Tim Harder <radhermit@gentoo.org> +abcm2ps-6.6.15.ebuild:
+ Version bump.
05 May 2012; Michał Górny <mgorny@gentoo.org> abcm2ps-6.6.7.ebuild,
abcm2ps-6.6.8.ebuild, abcm2ps-6.6.9.ebuild, abcm2ps-7.0.3.ebuild,
diff --git a/media-sound/abcm2ps/abcm2ps-6.6.15.ebuild b/media-sound/abcm2ps/abcm2ps-6.6.15.ebuild
new file mode 100644
index 000000000000..89983ecfd3b8
--- /dev/null
+++ b/media-sound/abcm2ps/abcm2ps-6.6.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/abcm2ps-6.6.15.ebuild,v 1.1 2012/05/29 12:29:27 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="A program to convert abc files to Postscript files"
+HOMEPAGE="http://moinejf.free.fr/"
+SRC_URI="http://moinejf.free.fr/${P}.tar.gz
+ http://moinejf.free.fr/transpose_abc.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pango"
+
+RDEPEND="pango? ( x11-libs/pango media-libs/freetype:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-a4 \
+ --enable-deco-is-roll \
+ $(use_enable pango)
+}
+
+src_install() {
+ dobin abcm2ps
+
+ insinto /usr/share/${PN}
+ doins *.fmt
+
+ dodoc Changes README *.txt
+
+ if use examples ; then
+ docinto examples
+ dodoc *.{abc,eps}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ docinto contrib
+ dodoc "${DISTDIR}"/transpose_abc.pl
+}