summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/mythweather/mythweather-0.15.ebuild')
-rw-r--r--media-plugins/mythweather/mythweather-0.15.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-plugins/mythweather/mythweather-0.15.ebuild b/media-plugins/mythweather/mythweather-0.15.ebuild
new file mode 100644
index 000000000000..46f0d5d621d3
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.15.ebuild,v 1.1 2004/06/01 17:23:26 aliz Exp $
+
+IUSE=""
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV}* >=media-tv/mythfrontend-${PV}* )"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}