summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdvdnav/libdvdnav-0.1.1.ebuild5
-rw-r--r--media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild19
2 files changed, 14 insertions, 10 deletions
diff --git a/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild b/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild
index 6d5be69c1a7d..1381bde8ee63 100644
--- a/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild
+++ b/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2002 Arcady Genkin <agenkin@thpoon.com>
# Distributed under the terms of the GNU General Public License, v2
-# Maintainer: Arcady Genkin <agenkin@thpoon.com>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild,v 1.1 2002/06/16 19:22:15 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild,v 1.2 2002/06/17 18:50:57 lostlogic Exp $
DESCRIPTION="Library for DVD navigation tools."
HOMEPAGE="http://sourceforge.net/projects/dvd/"
@@ -10,8 +9,10 @@ SRC_URI="mirror://sourceforge/dvd/${P}.tar.gz"
S=${WORKDIR}/${P}
LICENSE="GPL"
+SLOT="0"
DEPEND="media-libs/libdvdread"
+RDEPEND="${DEPEND}"
src_compile() {
diff --git a/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild b/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild
index 9ba2cdd97337..8d91ee33dbe6 100644
--- a/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# Author Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild,v 1.2 2002/06/17 08:41:38 naz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild,v 1.3 2002/06/17 18:50:57 lostlogic Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
@@ -18,10 +17,10 @@ DEPEND="X? ( virtual/x11 )
alsa? ( media-libs/alsa-lib )
aalib? ( media-libs/aalib )
oggvorbis? ( media-libs/libvorbis )"
-
RDEPEND="${DEPEND}
nls? ( sys-devel/gettext )"
+LICENSE="GPL"
SLOT="0"
src_unpack() {
@@ -46,12 +45,16 @@ src_compile() {
# the next release until then let it autodetect. See bug #2377.
# use aalib || myconf="${myconf} --disable-aalib --disable-aalibtest"
- use oggvorbis \
- || myconf="${myconf} --disable-ogg --disable-oggtest --disable-vorbis --disable-vorbistest"
+ use oggvorbis || myconf="${myconf}
+ --disable-ogg
+ --disable-oggtest
+ --disable-vorbis
+ --disable-vorbistest"
- use avi \
- && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
- || myconf="${myconf} --disable-asf"
+ use avi && myconf="${myconf}
+ --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf}
+ --disable-asf"
# This is ``fixes'' compilation problems when em8300 libs installed
# The proper fix is to follow.