summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdvbpsi/ChangeLog9
-rw-r--r--media-libs/libdvbpsi/libdvbpsi-0.1.7.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/media-libs/libdvbpsi/ChangeLog b/media-libs/libdvbpsi/ChangeLog
index d65b6c64fc75..5fb8a956701d 100644
--- a/media-libs/libdvbpsi/ChangeLog
+++ b/media-libs/libdvbpsi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libdvbpsi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/ChangeLog,v 1.40 2009/11/13 00:35:31 josejx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/ChangeLog,v 1.41 2010/04/23 11:40:24 aballier Exp $
+
+*libdvbpsi-0.1.7 (23 Apr 2010)
+
+ 23 Apr 2010; Alexis Ballier <aballier@gentoo.org> +libdvbpsi-0.1.7.ebuild:
+ version bump
13 Nov 2009; Joseph Jezak <josejx@gentoo.org> libdvbpsi-0.1.6.ebuild:
Marked ppc64 stable.
diff --git a/media-libs/libdvbpsi/libdvbpsi-0.1.7.ebuild b/media-libs/libdvbpsi/libdvbpsi-0.1.7.ebuild
new file mode 100644
index 000000000000..9a7f8c126210
--- /dev/null
+++ b/media-libs/libdvbpsi/libdvbpsi-0.1.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/libdvbpsi-0.1.7.ebuild,v 1.1 2010/04/23 11:40:24 aballier Exp $
+
+IUSE="doc"
+
+DESCRIPTION="library for MPEG TS/DVB PSI tables decoding and generation"
+HOMEPAGE="http://www.videolan.org/libdvbpsi"
+SRC_URI="http://download.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# doxygen missing: ~ia64
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="doc? (
+ >=app-doc/doxygen-1.2.16
+ media-gfx/graphviz
+ )"
+RDEPEND=""
+
+pkg_setup() {
+ if use doc; then
+ # Making the documentation requires that /usr/bin/dot from
+ # media-libs/graphviz supports PNG output.
+ # This is an automagic dependency :(, Bug #181147
+ # Check that /usr/bin/dot supports png by calling it with
+ # an unsupported format (-Txxx) to get a list of supported formats
+
+ if /usr/bin/dot -Txxx 2>&1 | grep -q png ; then
+ # dot supports png
+ :
+ else
+ die "You need to recompile media-gfx/graphviz with png support."
+ fi
+ fi
+}
+
+src_compile() {
+ econf --enable-release
+
+ emake || die "emake failed"
+
+ if use doc; then
+ einfo "Attempting to build documentation"
+ emake doc || die "Could not build documentation."
+ else
+ einfo "Documentation was not built"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ use doc && dohtml "${S}"/doc/doxygen/html/*
+ dodoc AUTHORS INSTALL README NEWS
+}