summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/xine-lib/xine-lib-1.1.5.ebuild')
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.5.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-libs/xine-lib/xine-lib-1.1.5.ebuild b/media-libs/xine-lib/xine-lib-1.1.5.ebuild
index 14114a91174a..7bc829f82d77 100644
--- a/media-libs/xine-lib/xine-lib-1.1.5.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.5.ebuild,v 1.1 2007/04/13 22:16:03 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.5.ebuild,v 1.2 2007/04/14 12:13:47 genstef Exp $
inherit eutils flag-o-matic toolchain-funcs libtool autotools
@@ -85,6 +85,12 @@ DEPEND="${RDEPEND}
sys-devel/libtool
nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/xine-lib-cdda-fix.patch
+}
+
src_compile() {
#prevent quicktime crashing
append-flags -frename-registers -ffunction-sections