summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/speex/speex-1.0.2.ebuild')
-rw-r--r--media-libs/speex/speex-1.0.2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-libs/speex/speex-1.0.2.ebuild b/media-libs/speex/speex-1.0.2.ebuild
index ff985c0a736b..50df973405f5 100644
--- a/media-libs/speex/speex-1.0.2.ebuild
+++ b/media-libs/speex/speex-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.0.2.ebuild,v 1.1 2003/11/20 23:09:53 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.0.2.ebuild,v 1.2 2003/11/29 23:10:52 brad_mssw Exp $
IUSE="oggvorbis sse"
@@ -13,7 +13,7 @@ SRC_URI="http://www.speex.org/download/${MY_P}.tar.gz"
SLOT="0"
LICENSE="BSD as-is"
-KEYWORDS="~x86 ~hppa"
+KEYWORDS="~x86 ~hppa amd64"
DEPEND="virtual/glibc
oggvorbis? ( >=media-libs/libogg-1.0 )"
@@ -22,8 +22,10 @@ src_compile() {
local myconf
use oggvorbis && myconf="--enable-ogg=yes --with-ogg-dir=/usr" \
|| myconf="--enable-ogg=no"
- use sse && myconf="${myconf} --enable-sse"
-
+ if [ "${ARCH}" != "amd64" ]
+ then
+ use sse && myconf="${myconf} --enable-sse"
+ fi
econf ${myconf} || die
emake || die
}