summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sdl-sound')
-rw-r--r--media-libs/sdl-sound/ChangeLog7
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/media-libs/sdl-sound/ChangeLog b/media-libs/sdl-sound/ChangeLog
index cdec253c3446..159a6ffa6ecb 100644
--- a/media-libs/sdl-sound/ChangeLog
+++ b/media-libs/sdl-sound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl-sound
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.33 2008/04/17 21:37:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.34 2008/04/20 21:09:54 vapier Exp $
+
+*sdl-sound-1.0.3 (20 Apr 2008)
+
+ 20 Apr 2008; Mike Frysinger <vapier@gentoo.org> +sdl-sound-1.0.3.ebuild:
+ Version bump.
*sdl-sound-1.0.2 (17 Apr 2008)
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild
new file mode 100644
index 000000000000..3ac7ddb20200
--- /dev/null
+++ b/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild,v 1.1 2008/04/20 21:09:54 vapier Exp $
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="A library that handles the decoding of sound file formats"
+HOMEPAGE="http://icculus.org/SDL_sound/"
+SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="flac mikmod vorbis speex physfs mp3 mpeg"
+
+RDEPEND=">=media-libs/libsdl-1.2
+ flac? ( media-libs/flac )
+ mikmod? ( >=media-libs/libmikmod-3.1.9 media-libs/libmodplug )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta4 )
+ speex? ( media-libs/speex media-libs/libogg )
+ physfs? ( dev-games/physfs )
+ mpeg? ( media-libs/smpeg )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-midi \
+ $(use_enable mpeg smpeg) \
+ $(use_enable mp3 mpglib) \
+ $(use_enable flac) \
+ $(use_enable speex) \
+ $(use_enable mikmod) \
+ $(use_enable mikmod modplug) \
+ $(use_enable physfs) \
+ $(use_enable vorbis ogg) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG CREDITS README TODO
+}