summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa-glu/mesa-glu-3.5.ebuild')
-rw-r--r--media-libs/mesa-glu/mesa-glu-3.5.ebuild102
1 files changed, 38 insertions, 64 deletions
diff --git a/media-libs/mesa-glu/mesa-glu-3.5.ebuild b/media-libs/mesa-glu/mesa-glu-3.5.ebuild
index a3a47664bc65..cd094c5a2568 100644
--- a/media-libs/mesa-glu/mesa-glu-3.5.ebuild
+++ b/media-libs/mesa-glu/mesa-glu-3.5.ebuild
@@ -1,78 +1,52 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa-glu/mesa-glu-3.5.ebuild,v 1.1 2001/06/23 17:22:11 achim Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa-glu/mesa-glu-3.5.ebuild,v 1.2 2002/01/13 21:26:50 drobbins Exp $
-P=MesaLib-${PV}
-A0=${P}.tar.bz2
-A1=MesaDemos-${PV}.tar.bz2
-A="${A0} ${A1}"
S=${WORKDIR}/Mesa-${PV}
DESCRIPTION="OpenGL like graphic library for Linux, this package only contains the glu and glut parts"
-SRC_URI="http://download.sourceforge.net/mesa3d/${A0}
- http://download.sourceforge.net/mesa3d/${A1}"
+SRC_URI="http://download.sourceforge.net/mesa3d/MesaLib-${PV}.tar.bz2
+ http://download.sourceforge.net/mesa3d/MesaDemos-${PV}.tar.bz2"
HOMEPAGE="http://mesa3d.sourceforge.net/"
DEPEND="virtual/glibc virtual/x11"
-
PROVIDE="virtual/glu virtual/glut"
-src_unpack() {
- unpack ${A}
- cd ${S}/si-glu/include
- ln -s ../../include/GL GL
-}
-
src_compile() {
-
- local myconf
-
- if [ "`use mmx`" ]
- then
- myconf="--enable-mmx"
- else
- myconf="--disable-mmx"
- fi
-
- if [ "`use 3dnow`" ]
- then
- myconf="${myconf} --enable-3dnow"
- else
- myconf="${myconf} --disable-3dnow"
- fi
-
- if [ "`use sse`" ]
- then
- myconf="${myconf} --enable-sse"
- else
- myconf="${myconf} --disable-sse"
- fi
-
- myconf="${myconf} --with-x --without-glut --disable-ggi-fbdev --without-ggi"
-
- try ./configure --prefix=/usr --sysconfdir=/etc/mesa --host=${CHOST} $myconf
-
- try make
-
+ local myconf
+ if [ "`use mmx`" ]
+ then
+ myconf="--enable-mmx"
+ else
+ myconf="--disable-mmx"
+ fi
+ if [ "`use 3dnow`" ]
+ then
+ myconf="${myconf} --enable-3dnow"
+ else
+ myconf="${myconf} --disable-3dnow"
+ fi
+ if [ "`use sse`" ]
+ then
+ myconf="${myconf} --enable-sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ myconf="${myconf} --with-x --without-glut --disable-ggi-fbdev --without-ggi"
+ ./configure --prefix=/usr --sysconfdir=/etc/mesa --host=${CHOST} $myconf || die
+ emake || die
}
-src_install () {
-
-
- cd ${S}
- try make DESTDIR=${D} install
- cd ${D}/usr/lib
-
- rm -f libGL.*
-
- rm -f ../include/GL/gl.h
- rm -f ../include/GL/glx.h
- rm -f ../include/GL/osmesa.h
-
- ln -s libGLU.so.1.3.350 libMesaGLU.so.3
-
-
- cd ${S}
- dodoc docs/*
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install || die
+ cd ${D}/usr/lib
+ rm -f libGL.*
+ rm -f ../include/GL/gl.h
+ rm -f ../include/GL/glx.h
+ rm -f ../include/GL/osmesa.h
+ ln -s libGLU.so.1.1.* libMesaGLU.so.3
+ cd ${S}
+ dodoc docs/*
}