summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libvisual/libvisual-0.1.6.ebuild')
-rw-r--r--media-libs/libvisual/libvisual-0.1.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libvisual/libvisual-0.1.6.ebuild b/media-libs/libvisual/libvisual-0.1.6.ebuild
new file mode 100644
index 000000000000..397583a38ed0
--- /dev/null
+++ b/media-libs/libvisual/libvisual-0.1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.1.6.ebuild,v 1.1 2004/09/15 21:16:52 eradicator Exp $
+
+IUSE="pic static"
+
+inherit eutils
+
+DESCRIPTION="Libvisual is an abstraction library that comes between applications and audio visualisation plugins."
+
+SRC_URI="http://osdn.dl.sourceforge.net/sourceforge/libvisual/${P}.tar.gz"
+HOMEPAGE="http://libvisual.sourceforge.net/"
+
+LICENSE="LGPL-2.1 GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-libdir.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ use pic && myconf="${myconf} --with-pic"
+ use static && myconf="${myconf} --enable-static"
+
+ econf $myconf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog HACKING MANIFESTO NEWS README TODO
+}