summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libpng/libpng-1.2.5-r7.ebuild')
-rw-r--r--media-libs/libpng/libpng-1.2.5-r7.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/media-libs/libpng/libpng-1.2.5-r7.ebuild b/media-libs/libpng/libpng-1.2.5-r7.ebuild
index fe68e8d7f0df..23a1c4a47595 100644
--- a/media-libs/libpng/libpng-1.2.5-r7.ebuild
+++ b/media-libs/libpng/libpng-1.2.5-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.5-r7.ebuild,v 1.1 2004/07/07 14:37:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.5-r7.ebuild,v 1.2 2004/07/11 03:47:33 pvdabeel Exp $
inherit flag-o-matic eutils gcc
@@ -19,7 +19,10 @@ src_unpack() {
unpack ${A}
cd ${S}
+
epatch ${FILESDIR}/${P}-gentoo.diff
+
+ use macos && epatch ${FILESDIR}/macos.patch # implements strnlen
[ "`gcc-version`" == "3.2" ] && replace-cpu-flags i586 k6 k6-2 k6-3
[ "`gcc-version`" == "3.3" ] && replace-cpu-flags i586 k6 k6-2 k6-3
@@ -31,6 +34,16 @@ src_unpack() {
-e "s:prefix=/usr/local:prefix=/usr:" \
-e "s:OBJSDLL = :OBJSDLL = -lz -lm :" \
scripts/makefile.linux > Makefile
+
+ if use macos; then
+ einfo "Patching the source for Mac OS X / Darwin compatibility"
+ sed \
+ -e "s:ZLIBLIB=.*:ZLIBLIB=/usr/lib:" \
+ -e "s:ZLIBINC=.*:ZLIBINC=/usr/include:" \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "s:prefix=/usr/local:prefix=/usr:" \
+ scripts/makefile.darwin > Makefile
+ fi
}
src_compile() {