summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gimp/gimp-1.3.15.ebuild')
-rw-r--r--media-gfx/gimp/gimp-1.3.15.ebuild57
1 files changed, 16 insertions, 41 deletions
diff --git a/media-gfx/gimp/gimp-1.3.15.ebuild b/media-gfx/gimp/gimp-1.3.15.ebuild
index beed9407d956..214f97e0f913 100644
--- a/media-gfx/gimp/gimp-1.3.15.ebuild
+++ b/media-gfx/gimp/gimp-1.3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.15.ebuild,v 1.1 2003/06/10 18:38:30 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.15.ebuild,v 1.2 2003/06/12 09:17:34 liquidx Exp $
IUSE="doc python perl aalib png jpeg tiff gtkhtml"
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
replace-flags -Os -O2
+MAKEOPTS="${MAKEOPTS} -j1"
RDEPEND=">=x11-libs/gtk+-2.2
>=x11-libs/pango-1.2
@@ -39,55 +40,29 @@ DEPEND="${RDEPEND}
doc? ( >=dev-util/gtk-doc-1 )"
src_compile() {
+ # workaround portage variable leakage
+ local AA
+ local myconf
# Strip out -fomit-frame-pointer for k6's
is-flag "-march=k6*" && filter-flags "-fomit-frame-pointer"
-
- local myconf
-
- use doc \
- && myconf="${myconf} --enable-gtk-doc" \
- || myconf="${myconf} --disable-gtk-doc"
- use python \
- && myconf="${myconf} --enable-python" \
- || myconf="${myconf} --disable-python"
- use perl \
- && myconf="${myconf} --enable-perl" \
- || myconf="${myconf} --disable-perl"
- use png \
- && myconf="${myconf} --with-libpng" \
- || myconf="${myconf} --without-libpng"
- use jpeg \
- && myconf="${myconf} --with-libjpeg" \
- || myconf="${myconf} --without-libjpeg"
- use tiff \
- && myconf="${myconf} --with-libtiff" \
- || myconf="${myconf} --without-libtiff"
- use gtkhtml \
- && myconf="${myconf} --with-libtiff" \
- || myconf="${myconf} --without-libtiff"
-
- myconf="${myconf} --disable-print"
-
- econf ${myconf} || die
-
-
- # hack for odd make break
- touch plug-ins/common/${P}.tar.bz2
-
+ econf ${myconf} \
+ `use_enable doc gtk-doc` \
+ `use_enable python` \
+ `use_enable perl` \
+ `use_with png libpng` \
+ `use_with jpeg libjpeg` \
+ `use_with tiff libtiff` || die
emake || die
}
src_install() {
- make DESTDIR=${D} prefix=/usr \
- sysconfdir=/etc \
- infodir=/usr/share/info \
- mandir=/usr/share/man \
- localstatedir=/var/lib \
- install || die
-
+ # workaround portage variable leakage
+ local AA
+
+ make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeL* HACKING INSTALL MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
}