summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/asymptote')
-rw-r--r--media-gfx/asymptote/ChangeLog11
-rw-r--r--media-gfx/asymptote/asymptote-1.20.ebuild15
-rwxr-xr-xmedia-gfx/asymptote/files/64asy-gentoo.el4
3 files changed, 26 insertions, 4 deletions
diff --git a/media-gfx/asymptote/ChangeLog b/media-gfx/asymptote/ChangeLog
index 0968904b6b98..bad10f528965 100644
--- a/media-gfx/asymptote/ChangeLog
+++ b/media-gfx/asymptote/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/asymptote
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.2 2007/02/18 12:04:48 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.3 2007/03/02 12:48:14 centic Exp $
+
+ 02 Mar 2007; Dominik Stadler <centic@gentoo.org> +files/64asy-gentoo.el,
+ asymptote-1.20.ebuild:
+ Add missing file 64asy-gentoo.el, add check for tk in python, add workaround
+ for problems with types.h and pid_t, fixes Bug 82871, thanks to Andrey
+ Grozin and Emiliano Vavassori for patches and suggestions.
+
+ 21 Feb 2007; Dominik Stadler <centic@gentoo.org> asymptote-1.20.ebuild:
+ Fix use-flags again, fixes Bug 167405
18 Feb 2007; Dominik Stadler <centic@gentoo.org> asymptote-1.20.ebuild:
Use vim-syntax instead of vim, fixes Bug 167405
diff --git a/media-gfx/asymptote/asymptote-1.20.ebuild b/media-gfx/asymptote/asymptote-1.20.ebuild
index 264699609283..b4829319b335 100644
--- a/media-gfx/asymptote/asymptote-1.20.ebuild
+++ b/media-gfx/asymptote/asymptote-1.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/asymptote-1.20.ebuild,v 1.2 2007/02/18 12:04:48 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/asymptote-1.20.ebuild,v 1.3 2007/03/02 12:48:14 centic Exp $
inherit eutils elisp-common
@@ -22,7 +22,7 @@ RDEPEND=">=sys-libs/readline-4.3-r5
fftw? ( >=sci-libs/fftw-3.0.1 )
emacs? ( virtual/emacs )
gsl? ( sci-libs/gsl )
- vim? ( app-editors/vim )"
+ vim-syntax? ( app-editors/vim )"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.5
>=sys-devel/bison-1.875
@@ -42,6 +42,14 @@ pkg_setup() {
die
fi
fi
+
+ if ! built_with_use dev-lang/python tk; then
+ eerror "Please reemerge dev-lang/python with 'tk' support or xasy will"
+ eerror "not work. In order to fix this, execute the following:"
+ eerror "echo \"dev-lang/python tk\" >> /etc/portage/package.use"
+ eerror "and reemerge dev-lang/python before emerging asymptote."
+ die "requires dev-lang/python with use-flag 'tk'!!"
+ fi
}
src_unpack() {
@@ -65,7 +73,8 @@ src_unpack() {
src_compile() {
for dir in `find /var/cache/fonts -type d`; do addwrite ${dir}; done
- myconf="--with-latex=/usr/share/texmf/tex/latex --disable-gc-debug"
+ # for the CPPFLAGS see http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ myconf="--with-latex=/usr/share/texmf/tex/latex --disable-gc-debug CPPFLAGS=-DHAVE_SYS_TYPES_H"
if use boehm-gc; then
myconf="${myconf} --enable-gc=system"
else
diff --git a/media-gfx/asymptote/files/64asy-gentoo.el b/media-gfx/asymptote/files/64asy-gentoo.el
new file mode 100755
index 000000000000..773c6602d9b3
--- /dev/null
+++ b/media-gfx/asymptote/files/64asy-gentoo.el
@@ -0,0 +1,4 @@
+;; begin asy-mode
+(autoload 'asy-mode "asy-mode.el" "Asymptote major mode." t)
+(setq auto-mode-alist (cons (cons "\\.asy$" 'asy-mode) auto-mode-alist))
+;; end asy-mode