summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/msmtp/msmtp-1.2.2.ebuild')
-rw-r--r--mail-mta/msmtp/msmtp-1.2.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/mail-mta/msmtp/msmtp-1.2.2.ebuild b/mail-mta/msmtp/msmtp-1.2.2.ebuild
new file mode 100644
index 000000000000..b9d83817da8d
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.2.2.ebuild,v 1.1 2004/09/01 11:44:53 ticho Exp $
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="http://msmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+IUSE="ssl gnutls sasl"
+DEPEND="virtual/libc
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.0.0 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ sasl? ( virtual/gsasl )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+src_compile () {
+ local myconf
+
+ use sasl \
+ && myconf="${myconf} --enable-gsasl" \
+ || myconf="${myconf} --disable-gsasl"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=gnutls"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=openssl"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS \
+ doc/msmtprc.example doc/Mutt+msmtp.txt || die "dodoc failed"
+}