summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/xfmail/xfmail-1.5.3.ebuild')
-rw-r--r--mail-client/xfmail/xfmail-1.5.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/mail-client/xfmail/xfmail-1.5.3.ebuild b/mail-client/xfmail/xfmail-1.5.3.ebuild
new file mode 100644
index 000000000000..4570fdb7380c
--- /dev/null
+++ b/mail-client/xfmail/xfmail-1.5.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/xfmail/xfmail-1.5.3.ebuild,v 1.1 2004/05/30 03:07:10 seemant Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A full-featured mail program using XForms"
+SRC_URI="ftp://ftp.xfmail.org/pub/${PN}/release/1.5.3/source/${P}.tar.bz2"
+HOMEPAGE="http://www.xfmail.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND="virtual/x11
+ >=x11-libs/xforms-1.0_rc4
+ ldap? ( >=net-nds/openldap-2.0.11 )"
+
+
+RDEPEND="virtual/x11
+ >=x11-libs/xforms-1.0_rc4
+ ldap? ( >=net-nds/openldap-2.0.11 )"
+
+src_compile() {
+
+ local myconf
+
+ use ldap && myconf="$myconf --with-ldap"
+
+ ./autogen.sh \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-faces $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS ChangeLog* NEWS README* TODO*
+
+}
+