summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r2.ebuild')
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r2.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r2.ebuild
new file mode 100644
index 000000000000..f00bc5213eed
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r2.ebuild,v 1.1 2005/07/23 20:16:33 anarchy Exp $
+
+inherit eutils mozilla-launcher
+
+DESCRIPTION="The Mozilla Thunderbird Mail & News Reader"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/linux-i686/en-US/thunderbird-${PV}.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird"
+RESTRICT="nostrip"
+
+KEYWORDS="-* amd64 x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-2.1.1
+ >=app-emulation/emul-linux-x86-gtklibs-2.1
+ )
+ >=www-client/mozilla-launcher-1.41"
+
+S=${WORKDIR}/thunderbird
+
+# This is a binary x86 package => ABI=x86
+# Please keep this in future versions
+# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+has_multilib_profile && ABI="x86"
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/thunderbird
+
+ # Install thunderbird in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ # Install /usr/bin/thunderbird-bin
+ install_mozilla_launcher_stub thunderbird-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozillathunderbird-bin-icon.png
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillathunderbird-bin.desktop
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/thunderbird
+
+ # Remove entire installed instance to solve various
+ # problems, for example see bug 27719
+ rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
+}
+
+pkg_postinst() {
+ einfo "For enigmail, please see instructions at"
+ einfo " http://enigmail.mozdev.org/"
+
+ if use amd64; then
+ echo
+ einfo "NB: You just installed a 32-bit thunderbird"
+ fi
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}