summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mailx-support')
-rw-r--r--mail-client/mailx-support/ChangeLog36
-rw-r--r--mail-client/mailx-support/Manifest5
-rw-r--r--mail-client/mailx-support/files/digest-mailx-support-200302151
-rw-r--r--mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch66
-rw-r--r--mail-client/mailx-support/mailx-support-20030215.ebuild28
-rw-r--r--mail-client/mailx-support/metadata.xml5
6 files changed, 141 insertions, 0 deletions
diff --git a/mail-client/mailx-support/ChangeLog b/mail-client/mailx-support/ChangeLog
new file mode 100644
index 000000000000..03f8b4798517
--- /dev/null
+++ b/mail-client/mailx-support/ChangeLog
@@ -0,0 +1,36 @@
+# ChangeLog for net-mail/mailx-support
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx-support/ChangeLog,v 1.1 2004/05/30 02:46:58 seemant Exp $
+
+*mailx-support-20030215 (29 May 2004)
+
+ 29 May 2004; Seemant Kulleen <seemant@gentoo.org> +metadata.xml,
+ +files/mailx-support-20030215-gentoo.patch, +mailx-support-20030215.ebuild:
+ Moved from net-mail/mailx-support to mail-client/mailx-support.
+
+ 27 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+ mailx-support-20030215.ebuild:
+ Add inherit eutils
+
+ 15 Jul 2003; Christian Birchinger <joker@gentoo.org>
+ mailx-support-20030215.ebuild:
+ Added sparc stable keyword
+
+*mailx-support-20030215 (09 Jun 2003)
+
+ 03 Aug 2003; Guy Martin <gmsoft@gentoo.org> mailx-support-20030215.ebuild :
+ Added hppa to KEYWORDS.
+
+ 10 Jun 2003; Joshua Kinard <kumba@gentoo.org> mailx-support-20030215.ebuild:
+ Fixed Security Violation -- ChangeLog missing from Manifest;
+ Fixed b0rked ebuild and moved source from ${FILESDIR} to a tarball;
+ Use 'epatch' instead of patch;
+ Removed 'die' statements;
+ Removed a few other things that harmed the ebuild;
+ Overall, fixed major brokeness;
+ Also added ~mips to KEYWORDS;
+
+ 09 Jun 2003; Nick Hadaway <raker@gentoo.org> mailx-support-20030215.ebuild,
+ files/digest-mailx-support-20030215, files/mailx-support-20030215/*,
+ files/mailx-support-20030215-gentoo.patch:
+ Added to support >=mailx-8.1.2's need for /usr/libexec/lockspool
diff --git a/mail-client/mailx-support/Manifest b/mail-client/mailx-support/Manifest
new file mode 100644
index 000000000000..bc3ddec7f453
--- /dev/null
+++ b/mail-client/mailx-support/Manifest
@@ -0,0 +1,5 @@
+MD5 b22c37b9f7ce7117c72421ccb0f07f31 ChangeLog 1249
+MD5 e242f138f73ebab67760e861b372693b mailx-support-20030215.ebuild 616
+MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
+MD5 e30d4b2f8fe8b19ca55cc584def34557 files/digest-mailx-support-20030215 73
+MD5 bf68aec6f17ac9cf58299e322196621d files/mailx-support-20030215-gentoo.patch 1793
diff --git a/mail-client/mailx-support/files/digest-mailx-support-20030215 b/mail-client/mailx-support/files/digest-mailx-support-20030215
new file mode 100644
index 000000000000..576f43350b13
--- /dev/null
+++ b/mail-client/mailx-support/files/digest-mailx-support-20030215
@@ -0,0 +1 @@
+MD5 b75582491fb0db904af9ca3c6a4cd8e0 mailx-support-20030215.tar.bz2 8194
diff --git a/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch b/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch
new file mode 100644
index 000000000000..829b85820488
--- /dev/null
+++ b/mail-client/mailx-support/files/mailx-support-20030215-gentoo.patch
@@ -0,0 +1,66 @@
+--- - 2003-02-15 23:35:46.000000000 +0800
++++ locking.c 2003-02-15 23:19:11.000000000 +0800
+@@ -45,6 +45,7 @@
+ #include <stdarg.h>
+ #include "pathnames.h"
+ #include "mail.local.h"
++#include "open_with_exlock.h"
+
+ static char lpath[MAXPATHLEN];
+
+@@ -93,7 +94,7 @@
+ }
+ goto again;
+ }
+- if ((lfd = open(lpath, O_CREAT|O_WRONLY|O_EXCL|O_EXLOCK,
++ if ((lfd = open_with_exlock(lpath, O_CREAT|O_WRONLY|O_EXCL,
+ S_IRUSR|S_IWUSR)) != -1)
+ break;
+ again:
+@@ -104,7 +105,7 @@
+ return(-1);
+ }
+ if (tries > 9 &&
+- (lfd = open(lpath, O_WRONLY|O_EXLOCK, 0)) != -1) {
++ (lfd = open_with_exlock(lpath, O_WRONLY, 0)) != -1) {
+ if (fstat(lfd, &fsb) != -1 &&
+ lstat(lpath, &sb) != -1) {
+ if (fsb.st_dev == sb.st_dev &&
+@@ -169,3 +170,4 @@
+ if (isfatal)
+ exit(1);
+ }
++
+--- - 2003-02-15 23:37:13.000000000 +0800
++++ mail.local.c 2003-02-15 23:20:50.000000000 +0800
+@@ -66,6 +66,7 @@
+ #include <string.h>
+ #include "pathnames.h"
+ #include "mail.local.h"
++#include "open_with_exlock.h"
+
+ int
+ main(int argc, char *argv[])
+@@ -218,7 +219,7 @@
+ merr(NOTFATAL, "%s: %s", path, strerror(errno));
+ goto bad;
+ }
+- if ((mbfd = open(path, O_APPEND|O_CREAT|O_EXCL|O_WRONLY|O_EXLOCK,
++ if ((mbfd = open_with_exlock(path, O_APPEND|O_CREAT|O_EXCL|O_WRONLY,
+ S_IRUSR|S_IWUSR)) < 0) {
+ if (errno == EEXIST) {
+ /* file appeared since lstat */
+@@ -244,7 +245,7 @@
+ merr(NOTFATAL, "%s: linked or special file", path);
+ goto bad;
+ }
+- if ((mbfd = open(path, O_APPEND|O_WRONLY|O_EXLOCK,
++ if ((mbfd = open_with_exlock(path, O_APPEND|O_WRONLY,
+ S_IRUSR|S_IWUSR)) < 0) {
+ merr(NOTFATAL, "%s: %s", path, strerror(errno));
+ goto bad;
+@@ -340,3 +341,4 @@
+ {
+ merr(FATAL, "usage: mail.local [-lL] [-f from] user ...");
+ }
++
diff --git a/mail-client/mailx-support/mailx-support-20030215.ebuild b/mail-client/mailx-support/mailx-support-20030215.ebuild
new file mode 100644
index 000000000000..348eff7ce181
--- /dev/null
+++ b/mail-client/mailx-support/mailx-support-20030215.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx-support/mailx-support-20030215.ebuild,v 1.1 2004/05/30 02:46:58 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Provides mail.local and lockspool"
+HOMEPAGE="http://www.openbsd.org/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc ~alpha ~mips hppa ia64 amd64"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ einstall
+}
diff --git a/mail-client/mailx-support/metadata.xml b/mail-client/mailx-support/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/mail-client/mailx-support/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>