summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.7.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 9175efe88bb0..8b71093404b8 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.183 2011/12/07 23:07:38 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.184 2011/12/11 18:52:26 alexxy Exp $
+
+*superkaramba-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +superkaramba-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-superkaramba-4.7.2-r1.ebuild:
diff --git a/kde-base/superkaramba/superkaramba-4.7.4.ebuild b/kde-base/superkaramba/superkaramba-4.7.4.ebuild
new file mode 100644
index 000000000000..a3407bcf7371
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.7.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.7.4.ebuild,v 1.1 2011/12/11 18:52:26 alexxy Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeutils"
+ kde_eclass="kde4-meta"
+fi
+inherit python ${kde_eclass}
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-as-needed.patch" )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ ${kde_eclass}_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ ${kde_eclass}_src_configure
+}