summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/solid/solid-4.6.4.ebuild')
-rw-r--r--kde-base/solid/solid-4.6.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/solid/solid-4.6.4.ebuild b/kde-base/solid/solid-4.6.4.ebuild
new file mode 100644
index 000000000000..56f3c3a226ad
--- /dev/null
+++ b/kde-base/solid/solid-4.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.6.4.ebuild,v 1.1 2011/06/10 17:59:59 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug bluetooth networkmanager wicd"
+
+DEPEND="
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep solid-runtime)
+"
+
+PDEPEND="bluetooth? ( net-wireless/bluedevil )"
+
+KMEXTRA="
+ libs/solid/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}