summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/phonon-kde/phonon-kde-4.7.1.ebuild')
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.7.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/phonon-kde/phonon-kde-4.7.1.ebuild b/kde-base/phonon-kde/phonon-kde-4.7.1.ebuild
new file mode 100644
index 000000000000..03b134a2dc20
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.7.1.ebuild,v 1.1 2011/09/07 20:14:08 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug xine pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3[xine?]
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with xine)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}