summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/oxygen-icons/oxygen-icons-4.8.0.ebuild')
-rw-r--r--kde-base/oxygen-icons/oxygen-icons-4.8.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-base/oxygen-icons/oxygen-icons-4.8.0.ebuild b/kde-base/oxygen-icons/oxygen-icons-4.8.0.ebuild
new file mode 100644
index 000000000000..1b7a191661c1
--- /dev/null
+++ b/kde-base/oxygen-icons/oxygen-icons-4.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/oxygen-icons-4.8.0.ebuild,v 1.1 2012/01/25 18:16:56 johu Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]]; then
+ KMNAME="kdesupport"
+else
+ # Upstream does not ship releases properly so we dont want all versions
+ MY_PV="4.8.0"
+ MY_P="${PN}-${MY_PV}"
+fi
+KDE_REQUIRED="never"
+inherit kde4-base
+
+DESCRIPTION="Oxygen SVG icon theme."
+HOMEPAGE="http://www.oxygen-icons.org/"
+# Note that the upstream tarball is .bz2, ours is .xz -- if upstream
+# changes its compression format to .xz, we will need to change the
+# filename of one of the tarballs
+[[ ${PV} == *9999 ]] || \
+SRC_URI="
+ !bindist? ( http://dev.gentoo.org/~dilfridge/distfiles/${MY_P}.tar.xz )
+ bindist? ( ${SRC_URI//${PV}/${MY_PV}} )
+"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="aqua bindist"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == *9999 ]] || S=${WORKDIR}/${MY_P}