summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/okular/okular-4.2.3.ebuild')
-rw-r--r--kde-base/okular/okular-4.2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/okular/okular-4.2.3.ebuild b/kde-base/okular/okular-4.2.3.ebuild
new file mode 100644
index 000000000000..93000d3ed5d9
--- /dev/null
+++ b/kde-base/okular/okular-4.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.2.3.ebuild,v 1.1 2009/05/07 00:16:06 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdegraphics"
+inherit kde4-meta
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="chm crypt debug djvu doc ebook +jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( media-libs/jpeg )
+ pdf? ( >=virtual/poppler-qt4-0.8.5 )
+ ps? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with chm CHM)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg JPEG)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff TIFF)"
+
+ kde4-meta_src_configure
+}