summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkworkspace/libkworkspace-4.7.4.ebuild')
-rw-r--r--kde-base/libkworkspace/libkworkspace-4.7.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/libkworkspace/libkworkspace-4.7.4.ebuild b/kde-base/libkworkspace/libkworkspace-4.7.4.ebuild
new file mode 100644
index 000000000000..0eeeca932ae9
--- /dev/null
+++ b/kde-base/libkworkspace/libkworkspace-4.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.7.4.ebuild,v 1.1 2011/12/11 18:52:38 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+KMMODULE="libs/kworkspace"
+inherit kde4-meta
+
+DESCRIPTION="A library for KDE desktop applications"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+KMEXTRACTONLY="
+ ksmserver/org.kde.KSMServerInterface.xml
+ kwin/org.kde.KWin.xml
+"
+
+KMSAVELIBS="true"
+
+DEPEND="
+ x11-libs/libxkbfile
+ x11-libs/libXcomposite
+"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i -e 's/install( FILES kdisplaymanager.h/install( FILES kdisplaymanager.h screenpreviewwidget.h/' \
+ libs/kworkspace/CMakeLists.txt || die "failed to provide screenpreviewwidget.h"
+
+ kde4-meta_src_prepare
+}