summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkcddb/libkcddb-4.8.5.ebuild')
-rw-r--r--kde-base/libkcddb/libkcddb-4.8.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/libkcddb/libkcddb-4.8.5.ebuild b/kde-base/libkcddb/libkcddb-4.8.5.ebuild
new file mode 100644
index 000000000000..dce2aa3824c4
--- /dev/null
+++ b/kde-base/libkcddb/libkcddb-4.8.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcddb/libkcddb-4.8.5.ebuild,v 1.1 2012/08/07 11:05:11 johu Exp $
+
+EAPI=4
+
+KMNAME="kdemultimedia"
+inherit kde4-meta
+
+DESCRIPTION="KDE library for CDDB"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT=test
+
+DEPEND="
+ musicbrainz? ( media-libs/musicbrainz:3 )
+"
+RDEPEND="${DEPEND}"
+add_blocker kscd "<4.8.4"
+
+KMSAVELIBS="true"
+
+KMEXTRACTONLY="
+ libkcddb/kcmcddb/doc
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with musicbrainz MusicBrainz3)
+ )
+
+ kde4-meta_src_configure
+}