summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kwin/kwin-4.4.4.ebuild')
-rw-r--r--kde-base/kwin/kwin-4.4.4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/kde-base/kwin/kwin-4.4.4.ebuild b/kde-base/kwin/kwin-4.4.4.ebuild
new file mode 100644
index 000000000000..2b7d8ba32d70
--- /dev/null
+++ b/kde-base/kwin/kwin-4.4.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.4.4.ebuild,v 1.1 2010/06/06 14:41:58 scarabeus Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug xcomposite xinerama"
+
+# NOTE disabled for now: captury? ( media-libs/libcaptury )
+COMMONDEPEND="
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch"
+)
+
+src_prepare() {
+# NOTE uncomment when enabled again by upstream
+# if ! use captury; then
+# sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+# -i kwin/effects/CMakeLists.txt || \
+# die "Making captury optional failed."
+# fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}