summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ksnapshot')
-rw-r--r--kde-base/ksnapshot/ChangeLog7
-rw-r--r--kde-base/ksnapshot/ksnapshot-4.7.1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/kde-base/ksnapshot/ChangeLog b/kde-base/ksnapshot/ChangeLog
index caf101a33f2e..f58765435dba 100644
--- a/kde-base/ksnapshot/ChangeLog
+++ b/kde-base/ksnapshot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksnapshot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksnapshot/ChangeLog,v 1.182 2011/08/15 20:09:31 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksnapshot/ChangeLog,v 1.183 2011/09/07 20:13:54 alexxy Exp $
+
+*ksnapshot-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksnapshot-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
15 Aug 2011; Markus Meier <maekke@gentoo.org> ksnapshot-4.6.5.ebuild:
x86 stable, bug #377465
diff --git a/kde-base/ksnapshot/ksnapshot-4.7.1.ebuild b/kde-base/ksnapshot/ksnapshot-4.7.1.ebuild
new file mode 100644
index 000000000000..97f639094a2c
--- /dev/null
+++ b/kde-base/ksnapshot/ksnapshot-4.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksnapshot/ksnapshot-4.7.1.ebuild,v 1.1 2011/09/07 20:13:54 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE Screenshot Utility"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug kipi"
+
+DEPEND="
+ kipi? ( $(add_kdebase_dep libkipi) )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.7-kipi.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with kipi)
+ )
+
+ kde4-base_src_configure
+}