summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kpdf/kpdf-3.5.10.ebuild')
-rw-r--r--kde-base/kpdf/kpdf-3.5.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kpdf/kpdf-3.5.10.ebuild b/kde-base/kpdf/kpdf-3.5.10.ebuild
new file mode 100644
index 000000000000..4c0f7cf76f96
--- /dev/null
+++ b/kde-base/kpdf/kpdf-3.5.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.5.10.ebuild,v 1.1 2008/09/13 23:59:27 carlo Exp $
+
+KMNAME=kdegraphics
+EAPI="1"
+inherit kde-meta flag-o-matic
+
+DESCRIPTION="kpdf, a kde pdf viewer based on xpdf"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+KMEXTRA="kfile-plugins/pdf"
+
+DEPEND=">=media-libs/freetype-2.3
+ media-libs/t1lib
+ >=app-text/poppler-0.6.1
+ >=app-text/poppler-bindings-0.6.1"
+RDEPEND="${DEPEND}
+ || ( >=kde-base/kdeprint-${PV}:${SLOT} >=kde-base/kdebase-${PV}:${SLOT} )"
+
+pkg_setup() {
+ kde_pkg_setup
+ # check for qt still until it had a revision bump in both ~arch and stable.
+ if ! built_with_use app-text/poppler-bindings qt3; then
+ eerror "This package requires app-text/poppler-bindings compiled with Qt 3.x support."
+ eerror "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ die "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ fi
+}
+
+src_compile() {
+ local myconf="--with-poppler"
+ replace-flags "-Os" "-O2" # see bug 114822
+
+ # Fix the desktop file.
+ sed -i -e "s:PDFViewer;:Viewer;:" "${S}/kpdf/shell/kpdf.desktop"
+
+ kde-meta_src_compile
+}