summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog8
-rw-r--r--kde-base/korundum/korundum-4.12.2.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 7cd9c79957c2..3412c0150434 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.195 2014/01/20 14:59:51 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.196 2014/02/06 23:20:25 dilfridge Exp $
+
+*korundum-4.12.2 (06 Feb 2014)
+
+ 06 Feb 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +korundum-4.12.2.ebuild:
+ Version bump KDE SC 4.12.2
20 Jan 2014; Michael Palimaka <kensington@gentoo.org>
-korundum-4.12.0.ebuild:
diff --git a/kde-base/korundum/korundum-4.12.2.ebuild b/kde-base/korundum/korundum-4.12.2.ebuild
new file mode 100644
index 000000000000..08e74edd595e
--- /dev/null
+++ b/kde-base/korundum/korundum-4.12.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.12.2.ebuild,v 1.1 2014/02/06 23:20:25 dilfridge Exp $
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+
+USE_RUBY="ruby19"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug kate okular"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+# unfortunately single modules cannot be disabled with cmake defines
+# possible more useflags have no effect... does anyone actually build this stuff?
+# may need some hacking, for now semantic-desktop just becomes a hard dependency
+
+DEPEND="
+ $(add_kdebase_dep qtruby)
+ $(add_kdebase_dep smokekde 'kate?,okular?,semantic-desktop')
+ $(add_kdebase_dep smokeqt)
+"
+RDEPEND="${DEPEND}
+"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}