summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kooka')
-rw-r--r--kde-base/kooka/ChangeLog7
-rw-r--r--kde-base/kooka/Manifest2
-rw-r--r--kde-base/kooka/files/digest-kooka-3.4.31
-rw-r--r--kde-base/kooka/kooka-3.4.3.ebuild26
4 files changed, 35 insertions, 1 deletions
diff --git a/kde-base/kooka/ChangeLog b/kde-base/kooka/ChangeLog
index 92004b543583..d86ab45cd707 100644
--- a/kde-base/kooka/ChangeLog
+++ b/kde-base/kooka/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kooka
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/ChangeLog,v 1.18 2005/10/11 09:45:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/ChangeLog,v 1.19 2005/10/13 00:10:04 danarmak Exp $
+
+*kooka-3.4.3 (13 Oct 2005)
+
+ 13 Oct 2005; Dan Armak <danarmak@gentoo.org> +kooka-3.4.3.ebuild:
+ New version.
11 Oct 2005; Diego Pettenò <flameeyes@gentoo.org> kooka-3.4.1.ebuild,
kooka-3.4.2.ebuild, kooka-3.5_beta1.ebuild:
diff --git a/kde-base/kooka/Manifest b/kde-base/kooka/Manifest
index c42b5f40404f..95ab92573c2d 100644
--- a/kde-base/kooka/Manifest
+++ b/kde-base/kooka/Manifest
@@ -2,9 +2,11 @@ MD5 2ec99581b83906e6ddaa1e495c23e549 ChangeLog 2787
MD5 51a35089fe1f6247f9cf221c77a57177 files/configure-fix-kdegraphics-kadmos.patch 1714
MD5 1334abaee53983ad0a0810adeafef453 files/digest-kooka-3.4.1 221
MD5 cb94e5a98246b8c80e29c3d668e4be9d files/digest-kooka-3.4.2 300
+MD5 ad9f9a5920cdd067ae76d39d768fce5f files/digest-kooka-3.4.3 71
MD5 40554f7678788d1d4cdcf0824da8434f files/digest-kooka-3.5_beta1 72
MD5 0abb98c262645006a4b116c0635edb49 files/kdegraphics-3.4.1-gocr.patch 454
MD5 6f27766dd3224f76199cd8d09b3f2be2 kooka-3.4.1.ebuild 690
MD5 90ad8660103053342c8b3242329df544 kooka-3.4.2.ebuild 1047
+MD5 90ad8660103053342c8b3242329df544 kooka-3.4.3.ebuild 1047
MD5 95e25bc29f5f6be0cee34d2cadaa6819 kooka-3.5_beta1.ebuild 694
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
diff --git a/kde-base/kooka/files/digest-kooka-3.4.3 b/kde-base/kooka/files/digest-kooka-3.4.3
new file mode 100644
index 000000000000..2cb888ba9f29
--- /dev/null
+++ b/kde-base/kooka/files/digest-kooka-3.4.3
@@ -0,0 +1 @@
+MD5 e2b2926301204a0f587d9e6e163c06d9 kdegraphics-3.4.3.tar.bz2 6554272
diff --git a/kde-base/kooka/kooka-3.4.3.ebuild b/kde-base/kooka/kooka-3.4.3.ebuild
new file mode 100644
index 000000000000..cf6c41244a95
--- /dev/null
+++ b/kde-base/kooka/kooka-3.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.4.3.ebuild,v 1.1 2005/10/13 00:10:04 danarmak Exp $
+
+KMNAME=kdegraphics
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="Kooka is a KDE application which provides access to scanner hardware"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kadmos"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkscan)
+ media-libs/tiff"
+OLDDEPEND="~kde-base/libkscan-$PV"
+
+KMCOPYLIB="libkscan libkscan"
+KMEXTRACTONLY="libkscan"
+
+# Fix detection of gocr (kde bug 90082). Applied to trunk upstream, but not backported to branch as of 3.4.2.
+PATCHES1="${FILESDIR}/kdegraphics-3.4.1-gocr.patch"
+
+# There's no ebuild for kadmos, and likely will never be since it isn't free, but you can enable this use flag
+# to compile against the kadmos headers you installed yourself
+PATCHES="$FILESDIR/configure-fix-kdegraphics-kadmos.patch"
+myconf="$myconf $(use_with kadmos)"