summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/konq-plugins/konq-plugins-4.7.1.ebuild')
-rw-r--r--kde-base/konq-plugins/konq-plugins-4.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-base/konq-plugins/konq-plugins-4.7.1.ebuild b/kde-base/konq-plugins/konq-plugins-4.7.1.ebuild
new file mode 100644
index 000000000000..514187e666d7
--- /dev/null
+++ b/kde-base/konq-plugins/konq-plugins-4.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/konq-plugins-4.7.1.ebuild,v 1.1 2011/09/07 20:13:57 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="Various plugins for konqueror"
+HOMEPAGE="http://kde.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tidy"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ tidy? ( app-text/htmltidy )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/konq-plugins
+ $(add_kdebase_dep kcmshell)
+ $(add_kdebase_dep konqueror)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKdeWebKit=OFF
+ -DWebKitPart=OFF
+ $(cmake-utils_use_with tidy LibTidy)
+ )
+
+ kde4-meta_src_configure
+}