summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kig/kig-4.7.0.ebuild')
-rw-r--r--kde-base/kig/kig-4.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kig/kig-4.7.0.ebuild b/kde-base/kig/kig-4.7.0.ebuild
new file mode 100644
index 000000000000..9e678671c4c9
--- /dev/null
+++ b/kde-base/kig/kig-4.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-4.7.0.ebuild,v 1.1 2011/07/27 14:04:36 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE Interactive Geometry tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug kig-scripting"
+
+DEPEND="
+ kig-scripting? ( >=dev-libs/boost-1.32 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with kig-scripting BoostPython)
+ )
+
+ kde4-base_src_configure
+}