summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog8
-rw-r--r--kde-base/kdepim-runtime/files/kdepim-runtime-4.7.1-emptyids.patch36
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.7.1-r1.ebuild35
3 files changed, 78 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 6352a3594120..c0aab8fbe82b 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.47 2011/09/07 20:13:45 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.48 2011/09/27 23:35:50 dilfridge Exp $
+
+*kdepim-runtime-4.7.1-r1 (27 Sep 2011)
+
+ 27 Sep 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdepim-runtime-4.7.1-r1.ebuild, +files/kdepim-runtime-4.7.1-emptyids.patch:
+ Backport fix for potential mail loss bug, from packagers ml
*kdepim-runtime-4.7.1 (07 Sep 2011)
diff --git a/kde-base/kdepim-runtime/files/kdepim-runtime-4.7.1-emptyids.patch b/kde-base/kdepim-runtime/files/kdepim-runtime-4.7.1-emptyids.patch
new file mode 100644
index 000000000000..2a8397dd508c
--- /dev/null
+++ b/kde-base/kdepim-runtime/files/kdepim-runtime-4.7.1-emptyids.patch
@@ -0,0 +1,36 @@
+From ccd67f3e65c9ffe32858ca521aa1e56a42b026af Mon Sep 17 00:00:00 2001
+From: Volker Krause <vkrause@kde.org>
+Date: Tue, 20 Sep 2011 10:12:40 +0200
+Subject: [PATCH] Ignore items with empty remote ids here.
+
+Items with empty remote id are those not yet stored by the resource,
+ie. we still have pending change replays for those. So, if we do a sync
+during that period (which could happen since the introduction of the
+file system watcher), we would remove a random one of those (only one
+since the map would only contain one without a remote id). This mostly
+affects the POP3 usage pattern.
+(cherry picked from commit f814b46a799ea8418ae17cf77d44da473124d12d)
+---
+ resources/maildir/retrieveitemsjob.cpp | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/resources/maildir/retrieveitemsjob.cpp b/resources/maildir/retrieveitemsjob.cpp
+index 7253f7e..f0273ef 100644
+--- a/resources/maildir/retrieveitemsjob.cpp
++++ b/resources/maildir/retrieveitemsjob.cpp
+@@ -57,8 +57,10 @@ void RetrieveItemsJob::localListDone ( KJob* job )
+
+ const Akonadi::Item::List items = qobject_cast<Akonadi::ItemFetchJob*>( job )->items();
+ m_localItems.reserve( items.size() );
+- foreach ( const Akonadi::Item &item, items )
+- m_localItems.insert( item.remoteId(), item );
++ foreach ( const Akonadi::Item &item, items ) {
++ if ( !item.remoteId().isEmpty() )
++ m_localItems.insert( item.remoteId(), item );
++ }
+
+ const QStringList entryList = m_maildir.entryList();
+ qint64 previousMtime = m_collection.remoteRevision().toLongLong();
+--
+1.7.1
+
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.7.1-r1.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..d5a8607eac69
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.7.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.7.1-r1.ebuild,v 1.1 2011/09/27 23:35:50 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdepim-runtime"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.3.60
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.6.51
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+"
+
+add_blocker kdemaildir '<4.3.0'
+add_blocker akonadi '<4.3.90'
+
+PATCHES=( "${FILESDIR}/${P}-emptyids.patch" )