summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin/dolphin-4.6.1.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.6.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.6.1.ebuild b/kde-base/dolphin/dolphin-4.6.1.ebuild
new file mode 100644
index 000000000000..df67e5ef75c3
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.6.1.ebuild,v 1.1 2011/03/04 18:00:16 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}